Modify

Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#18583 closed defect (fixed)

UnsatisfiedLinkError: sun.nio.fs.LinuxWatchService.inotifyInit

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone: 20.01
Component: Core Version:
Keywords: template_report linux freebsd Cc:

Description

What steps will reproduce the problem?

  1. Start josm

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Build-Date:2020-01-02 21:52:31
Revision:15628
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15628 ru) FreeBSD
Memory Usage: 442 MB / 912 MB (336 MB allocated, but free)
Java version: 1.8.0_242-b07, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 2304x1024, :0.1 1024x768
Maximum Screen Size: 2304x1024

Plugins:
+ DirectDownload
+ InfoMode
+ editgpx

Last errors/warnings:
- E: Handled by bug report queue: java.lang.UnsatisfiedLinkError: sun.nio.fs.LinuxWatchService.inotifyInit()I


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.UnsatisfiedLinkError: sun.nio.fs.LinuxWatchService.inotifyInit()I
	at sun.nio.fs.LinuxWatchService.inotifyInit(Native Method)
	at sun.nio.fs.LinuxWatchService.<init>(LinuxWatchService.java:59)
	at sun.nio.fs.BsdFileSystem.newWatchService(BsdFileSystem.java:51)
	at org.openstreetmap.josm.io.FileWatcher.<init>(FileWatcher.java:55)
	at org.openstreetmap.josm.io.FileWatcher$InstanceHolder.<clinit>(FileWatcher.java:38)
	at org.openstreetmap.josm.io.FileWatcher.getDefaultInstance(FileWatcher.java:47)
	at org.openstreetmap.josm.gui.MainInitialization.beforeInitializationTasks(MainInitialization.java:72)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:71)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)

Attachments (0)

Change History (4)

comment:1 Changed 15 months ago by Don-vip

Keywords: linux freebsd added
Summary: crash on startUnsatisfiedLinkError: sun.nio.fs.LinuxWatchService.inotifyInit

comment:2 Changed 15 months ago by Don-vip

Milestone: 20.01
Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 15 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15738/josm:

fix #18583 - FileWatcher: catch possible exceptions thrown by FileSystem.newWatchService

comment:4 Changed 15 months ago by Don-vip

Ticket #18618 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.