Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18584 closed defect (invalid)

Regex searching with ^ does not seem to work properly

Reported by: pangoSE Owned by: pangoSE
Priority: normal Milestone:
Component: Core Version:
Keywords: search regex Cc:

Description

Reproduce:
Download from overpass: image~/commons\.wikimedia\.org/ in schleswig-holstein
Search using this expression for image= tags which begin the correct url and do not already have a wikimedia_commons tag:
image="^https://commons.*" -wikimedia_commons

The search returns image tags which start with another url:
see image

According to the referenced regex in the wiki: http://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html it should work to only match "beginning of a line".

Attachments (2)

regex-error.jpg (187.5 KB) - added by pangoSE 3 months ago.
2020-01-20-203118_1119x513_scrot.png (28.5 KB) - added by simon04 3 months ago.

Download all attachments as: .zip

Change History (8)

Changed 3 months ago by pangoSE

Attachment: regex-error.jpg added

comment:2 Changed 3 months ago by Don-vip

Keywords: overpass regex added

Changed 3 months ago by simon04

comment:3 Changed 3 months ago by simon04

Owner: changed from team to pangoSE
Status: newneedinfo

I cannot reproduce using attachment:2020-01-20-203118_1119x513_scrot.png

Please provide a small data set and a search query to illustrate the problem.

comment:4 Changed 3 months ago by pangoSE

Hi! Thanks a lot for your attention to this. I just found out that I might have misunderstood the drop-down dialog (the values of the selection are italic with number of occurences afterwards). I'm sorry for the noise, we can close this.

comment:5 Changed 3 months ago by simon04

Resolution: invalid
Status: needinfoclosed

comment:6 Changed 3 months ago by simon04

Keywords: search added; overpass removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pangoSE.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.