Modify

Opened 7 weeks ago

Closed 3 weeks ago

Last modified 3 weeks ago

#18503 closed enhancement (fixed)

Show continuity line next to sub route relations members of route relations

Reported by: Polyglot Owned by: team
Priority: normal Milestone: 20.01
Component: Core Version:
Keywords: route relations segment tagging Cc:

Description

Hi,

When using route relations as members of route relations, it's not possible anymore to see whether the ways inside the sub route relation have a node in common with either the way just before or after, or with the last or first way in the previous sub route relation.

For mapping public transport I want to propose that we map the itineraries as sequences of sub route relations. Without editor support, it doesn't make sense to make such a proposal.

What is nice about the current way of having all the ways over and over again in the route relations, is that it's possible to visually check for continuity. It does cause a lot of overhead with ways being members in very many route relations. It's also making maintenance a lot harder than it should be.

There are also people who would like to see the stops inbetween the ways. Maybe we could also have a continuity line next to such a node, if the way just before and the way just after (or their counterparts in the sub route relations) have a node in common? If people add platform ways, maybe we can use a cross? (I don't like to add the platform ways to the route relations, but that's another story. My preference is to add a single platform node for each stop)

Attachments (2)

18503.osm (133.4 KB) - added by Don-vip 6 weeks ago.
2020-01-19-183652_754x826_scrot.png (32.8 KB) - added by simon04 4 weeks ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 7 weeks ago by Don-vip

Owner: changed from team to Polyglot
Status: newneedinfo

Can you please share a sample data set?

comment:2 Changed 7 weeks ago by Polyglot

Hi Vincent,

I converted some bus lines to this way of mapping:

https://www.openstreetmap.org/relation/1192349
https://www.openstreetmap.org/relation/1600357

These are both directions of the same line.

comment:3 Changed 6 weeks ago by Polyglot

Owner: changed from Polyglot to team
Status: needinfonew

Changed 6 weeks ago by Don-vip

Attachment: 18503.osm added

comment:4 Changed 6 weeks ago by skyper

While I do not like this approach for public transport and I think you should use multilinestring-Relations instead of route-Relations for the small child relations or superroute instead of route for the full route, I still think we need some improvements of the continuity line.

E.g.:

  • route relation with members of type node in between the way (stops, guideposts, ...)
  • superroute
  • turn-restriction with via node in between ways

comment:5 Changed 6 weeks ago by Polyglot

if/when I do make the proposal to map public transport this way, I would prefer to use superroute for the routes as we have them today.

This way the rendering will remain the same during the transition period. All the small child relations will continue to be rendered.

For the superroute relations a different, possibly better rendering becomes a possibility.

The main purpose of doing it this way would be to make maintenance easier. If a child route gets broken, you fix it once, with the result that all the superroutes are fixed immediately.

It's something I'm thinking about for several years already. At some point there were mappers who complained about the ways being in so many route relations. Maybe I should have proposed it then, as there was 'momentum'. More recently someone thought it would be more logical to put the stops in between the ways. Not sure if that would work very well, if the ways are shipped off to subroute relations, but still feasible, I think.

What I don't want to do is add the stops to those subroute relations. As far as I'm concerned the sequence of stops in a itinerary serves as its 'signature'.

comment:6 in reply to:  5 ; Changed 6 weeks ago by skyper

Replying to Polyglot:

I converted some bus lines to this way of mapping:

https://www.openstreetmap.org/relation/1192349
https://www.openstreetmap.org/relation/1600357

These are both directions of the same line.

Think it would be better to duplicate the routes for experiences than changing the existing ones. This way, you could already use superroute and you will not break existing schemes. Please, do not add public_transport:version=2 to the parts. Thanks

Replying to Polyglot:

if/when I do make the proposal to map public transport this way, I would prefer to use superroute for the routes as we have them today.

This way the rendering will remain the same during the transition period. All the small child relations will continue to be rendered.

For the superroute relations a different, possibly better rendering becomes a possibility.

The main purpose of doing it this way would be to make maintenance easier. If a child route gets broken, you fix it once, with the result that all the superroutes are fixed immediately.

Not sure about how the total numbers of relation with change this way. For sure we would have some areas with lots of short relations like bus stations and major city roads with lots of intersections but other areas would be really simple.

It's something I'm thinking about for several years already. At some point there were mappers who complained about the ways being in so many route relations. Maybe I should have proposed it then, as there was 'momentum'.

It will be harder to obtain the (bus) lines running on a certain way as they gonna be hidden in the superroute's name and looking at route_ref of the small parts is cumbersome.

More recently someone thought it would be more logical to put the stops in between the ways. Not sure if that would work very well, if the ways are shipped off to subroute relations, but still feasible, I think.

Do not like this, as you would have to split the ways at each stop. Plus see below.

What I don't want to do is add the stops to those subroute relations. As far as I'm concerned the sequence of stops in a itinerary serves as its 'signature'.

+1
Stops in subroutes will not work well if not all routes stop at all possibilities.

comment:7 in reply to:  6 Changed 6 weeks ago by Polyglot

Replying to skyper:

Replying to Polyglot:

I converted some bus lines to this way of mapping:

https://www.openstreetmap.org/relation/1192349
https://www.openstreetmap.org/relation/1600357

These are both directions of the same line.

Think it would be better to duplicate the routes for experiences than changing the existing ones. This way, you could already use superroute and you will not break existing schemes. Please, do not add public_transport:version=2 to the parts. Thanks

I did that to silence the validator's warning. Maybe not the best idea. I did this exercise already a few years ago, back then I duplicated them indeed, but in the mean time I removed all the subroutes, don't remember why anymore. Maybe I should have resurrected them.

It will be harder to obtain the (bus) lines running on a certain way as they gonna be hidden in the superroute's name and looking at route_ref of the small parts is cumbersome.

True, that's a disadvantage. I have no idea how this proposal will be received. Probably not too well, we'll see.
What I also wanted to do, is to add colour to the subroute relations with a list of colours separated by semicolons. This should make it easier to create a style that shows them like a metro 'spider' map. But since there will usually be a subroute relation for each direction of travel, maybe not all that easy, after all.

More recently someone thought it would be more logical to put the stops in between the ways. Not sure if that would work very well, if the ways are shipped off to subroute relations, but still feasible, I think.

Do not like this, as you would have to split the ways at each stop. Plus see below.

Yes, that's what probably would happen then, making the whole thing more complex again. So let's keep them on as the first elements in the superroute. If someone would add one in between two ways with nodes in common, it would still be nice to show a continuity line next to them, I think. Maybe with a dot on it?

What I don't want to do is add the stops to those subroute relations. As far as I'm concerned the sequence of stops in an itinerary serves as its 'signature'.

+1
Stops in subroutes will not work well if not all routes stop at all possibilities.

Indeed.

comment:8 Changed 4 weeks ago by simon04

Keywords: route relations segment tagging added

There's also

I think a the connectivity icon can be computed for sub-relations. However, JOSM should not anticipate a certain tagging scheme.

comment:9 in reply to:  8 Changed 4 weeks ago by skyper

Replying to simon04:

There's also

I think a the connectivity icon can be computed for sub-relations. However, JOSM should not anticipate a certain tagging scheme.

How about supporting superroutes ?

comment:10 Changed 4 weeks ago by simon04

In 15732/josm:

see #18503 - Relation editor: compute wayConnection for type=superroute

This basic implementation only considers route segments without a role
(as specified for public_transport:version=2; no forward/backward)
and does not take roundabouts into account.

Changed 4 weeks ago by simon04

comment:11 Changed 4 weeks ago by simon04

Implemented for type=superroute


comment:12 Changed 4 weeks ago by simon04

Milestone: 20.01

comment:13 Changed 4 weeks ago by simon04

Ticket #16479 has been marked as a duplicate of this ticket.

comment:14 Changed 3 weeks ago by simon04

Resolution: fixed
Status: newclosed

comment:15 in reply to:  4 Changed 3 weeks ago by skyper

Replying to skyper:

While I do not like this approach for public transport and I think you should use multilinestring-Relations instead of route-Relations for the small child relations or superroute instead of route for the full route, I still think we need some improvements of the continuity line.

E.g.:

  • route relation with members of type node in between the way (stops, guideposts, ...)
  • superroute
  • turn-restriction with via node in between ways

Should I open a new ticket for turn-restrictions and guideposts ?

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.