Modify

Opened 6 months ago

Closed 5 months ago

Last modified 5 months ago

#18419 closed defect (duplicate)

Moving node can change information about download area

Reported by: skyper Owned by: skyper
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report move node download area Cc:

Description

What steps will reproduce the problem?

  1. select a way node outside download area
  2. move it inside download area
  3. use the node as starting node for a new way
  4. unglue ways

What is the expected result?

A warning that I am ungluing at a node outside of download area

What happens instead?

No warning

Please provide any additional information below. Attach a screenshot if possible.

Same is true for the other way around.

What steps will reproduce the problem?

  1. download a node with two parents
  2. move it outside download area
  3. unglue

What is the expected result?

No warning

What happens instead?

A warning that I am ungluing at a node outside of download area

Please provide any additional information below. Attach a screenshot if possible.

This can be more tricky, considering more actions on the node like connecting ways after moving it outside of download area but in advance of ungluing. I would be more conservative with this case and rather show a warning.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-11 22:32:02 +0100 (Wed, 11 Dec 2019)
Revision:15584
Build-Date:2019-12-12 02:30:59
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (4)

comment:1 Changed 6 months ago by GerdP

I don't understand how the title is related to the rest of the ticket. The node is never incomplete in your scenarios.
If I got that right you try to describe here and in #18414 that there are several ways to produce data which can cause conflicts on upload or which can "confuse" the validator tests. Is this the problem you want to get fixed?
See also ticket:18240#comment:7

Last edited 6 months ago by GerdP (previous) (diff)

comment:2 Changed 6 months ago by Don-vip

Owner: changed from team to skyper
Status: newneedinfo

comment:3 in reply to:  1 ; Changed 5 months ago by skyper

Resolution: duplicate
Status: needinfoclosed
Summary: Moving node can change incomplete statusMoving node can change information about download area

Closed as duplicate of #10999.
Replying to GerdP:

I don't understand how the title is related to the rest of the ticket. The node is never incomplete in your scenarios.

You are right. It is about download area information.

If I got that right you try to describe here and in #18414 that there are several ways to produce data which can cause conflicts on upload or which can "confuse" the validator tests. Is this the problem you want to get fixed?

Yes

See also ticket:18240#comment:7

Warnings when deleting and unglueing need the information about download area, too.

Anyway, this is more or less a duplicate of #10999. Strange, I did not find it last time. Sorry

comment:4 in reply to:  3 Changed 5 months ago by skyper

Replying to skyper:

Replying to GerdP:

If I got that right you try to describe here and in #18414 that there are several ways to produce data which can cause conflicts on upload or which can "confuse" the validator tests. Is this the problem you want to get fixed?

Yes

See also #18083

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain skyper.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.