Modify

Opened 5 weeks ago

Closed 5 weeks ago

#18059 closed defect (fixed)

MAPCSS ParseException: Encountered at line 1259, column 14

Reported by: skyper Owned by: Klumbumbus
Priority: normal Milestone: 19.08
Component: Core validator Version: latest
Keywords: template_report ParseException regression Cc:

Description

What steps will reproduce the problem?

  1. start JOSM
  2. watch console log


What is the expected result?

No exception

What happens instead?

org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "*" "* "" at line 1259, column 14

Please provide any additional information below. Attach a screenshot if possible.

Quite new, last two/three days introduced.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-08-21 00:04:41 +0200 (Wed, 21 Aug 2019)
Build-Date:2019-08-21 01:31:05
Revision:15309
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15309 en) Linux Debian GNU/Linux 9.9 (stretch)
Memory Usage: 287 MB / 711 MB (155 MB allocated, but free)

VM arguments: [-Djosm.home=.josm_test]

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [TMS_BLOCK_v2] Resetting cache
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "*" "* "" at line 1259, column 14.

console output:

2019-08-21 16:23:10.414 INFO: Log level is at INFO (INFO, 800)
2019-08-21 16:23:22.811 WARNING: No configuration settings found.  Using hardcoded default values for all pools.
2019-08-21 16:23:23.018 WARNING: Region [TMS_BLOCK_v2] Resetting cache
2019-08-21 16:23:23.326 INFO: Changeset updater active (checks every 60 minutes if open changesets have been closed)
2019-08-21 16:23:27.236 SEVERE: Skipping to the next rule, because of an error:
2019-08-21 16:23:27.239 SEVERE: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "*" "* "" at line 1259, column 14.
Was expecting one of:
    "set" ...
    <IDENT> ...
    <UINT> ...
    <STRING> ...
    "(" ...
    <UFLOAT> ...
    <HEXCOLOR> ...
    <S> ...
    "=" ...
    "!" ...
    "+" ...
    "-" ...
    "/*" ...
    <S> ...
    <IDENT> ...
    "set" ...
org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "*" "* "" at line 1259, column 14.
Was expecting one of:
    "set" ...
    <IDENT> ...
    <UINT> ...
    <STRING> ...
    "(" ...
    <UFLOAT> ...
    <HEXCOLOR> ...
    <S> ...
    "=" ...
    "!" ...
    "+" ...
    "-" ...
    "/*" ...
    <S> ...
    <IDENT> ...
    "set" ...
    
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.error_skipto(MapCSSParser.java:2189)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.sheet(MapCSSParser.java:896)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.readMapCSS(MapCSSTagChecker.java:397)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.addMapCSS(MapCSSTagChecker.java:824)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.initialize(MapCSSTagChecker.java:853)
	at org.openstreetmap.josm.data.validation.OsmValidator.initializeTests(OsmValidator.java:585)
	at org.openstreetmap.josm.data.validation.OsmValidator.initializeTests(OsmValidator.java:568)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

2019-08-21 16:25:04.479 INFO: POST https://josm.openstreetmap.de/josmticket (1.53 kB) ...
2019-08-21 16:25:05.476 INFO: POST https://josm.openstreetmap.de/josmticket -> HTTP_1 200
2019-08-21 16:25:05.608 INFO: Opening URL: https://josm.openstreetmap.de/josmticket?pdata_stored=a749db58d46b1b31006a54e4

Attachments (0)

Change History (2)

comment:1 Changed 5 weeks ago by Klumbumbus

Component: Core mappaintCore validator
Keywords: regression added
Milestone: 19.08
Owner: changed from team to Klumbumbus
Status: newassigned

regression from r15309

comment:2 Changed 5 weeks ago by Klumbumbus

Resolution: fixed
Status: assignedclosed

In 15310/josm:

fix #18059, see #17786 - fix validator rule

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.