Modify

Opened 4 months ago

Closed 4 weeks ago

Last modified 4 weeks ago

#17786 closed enhancement (fixed)

Complain about misusing building key to describe building state (building=damaged, building=collapsed)

Reported by: mkoniecz Owned by: Klumbumbus
Priority: normal Milestone: 19.08
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. Create closed way with building=damaged or building=collapsed tag
  2. Run validator

What is the expected result?

Validator complains that building key should be used to store building type - for example building constructed as a church should have building=church

What happens instead?

Presets do not contain property value - Value 'collapsed' for key 'building' not in presets. (1)

Please provide any additional information below. Attach a screenshot if possible.

I am willing to implement a patch. I am unsure what, if anything, should be proposed as an alternative tagging.

This mistaggings are widely used, likely as result of low quality HOT mapping resulting from poor instructions guiding newbie mappers.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-06-03 22:39:22 +0200 (Mon, 03 Jun 2019)
Build-Date:2019-06-03 20:47:14
Revision:15158
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15158 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 481 MB / 869 MB (156 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34977)
+ PicLayer (35027)
+ buildings_tools (34982)
+ continuosDownload (82)
+ ejml (34908)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jts (34908)
+ log4j (34908)
+ measurement (34977)
+ reverter (34999)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: Invalid jar file ''<josm.userdata>/plugins/reverter.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.userdata>/plugins/PicLayer.jar.new'' (exists: false, canRead: false)
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Bad Request - org.openstreetmap.josm.gui.widgets.HtmlPanel[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]

Attachments (0)

Change History (5)

comment:1 Changed 4 months ago by mkoniecz

Description: modified (diff)
Summary: Complain about misusing building key to describ building state (building=damaged, building=collapsed)Complain about misusing building key to describe building state (building=damaged, building=collapsed)

comment:2 Changed 4 weeks ago by Klumbumbus

Milestone: 19.08
Owner: changed from team to Klumbumbus

comment:3 in reply to:  description Changed 4 weeks ago by Klumbumbus

Replying to mkoniecz:

I am unsure what, if anything, should be proposed as an alternative tagging.

Possible replacements could be lifecycle prefixes or ruins=yes but this is controversial as well, and the building key should be kept or not depending on the specific case, so we better don't suggest an alternative. Just warn "...is not a building type."
The building key seems to be a dumping ground for any possible value anyway. More than 10k different values. building=bing -_-

comment:4 Changed 4 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 15309/josm:

fix #17786 - warn about most used non-building-type building values (abandoned,address,bing,collapsed,damaged,demolished,disused,fixme,occupied,other,razed,unclassified,undefined,unknown,unidentified,true,*,Y)

comment:5 Changed 4 weeks ago by Klumbumbus

In 15310/josm:

fix #18059, see #17786 - fix validator rule

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Klumbumbus.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.