Modify

#17820 closed enhancement (fixed)

Render oneway:bicycle=no like cycleway=opposite

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 20.02
Component: Internal mappaint style Version:
Keywords: template_report cycleway bicycle oneway Cc:

Description

What steps will reproduce the problem?

  1. Create way, tag it with highway=residential, oneway=yes
  2. Add oneway:bicycle=no
  3. Add cycleway=opposite

What is the expected result?

Step 2 is changing rendering to indicate bidirectional access for cyclists

What happens instead?

Step 3 is necessary to achieve this.

Please provide any additional information below. Attach a screenshot if possible.

While I slightly prefer cycleway=opposite + oneway:bicycle=no for marking contraflow without bicycle lane, it seems that cycleway=no + oneway:bicycle=no for representing this situation is considered at least acceptable.

For me it seems that it would be OK to support both tagging schemes, including rendering in mappaint.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-06-12 22:04:53 +0200 (Wed, 12 Jun 2019)
Build-Date:2019-06-13 01:30:52
Revision:15169
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15169 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 538 MB / 869 MB (296 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34977)
+ PicLayer (35030)
+ buildings_tools (34982)
+ continuosDownload (82)
+ ejml (34908)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jts (34908)
+ log4j (34908)
+ measurement (34977)
+ reverter (34999)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (6)

comment:1 Changed 14 months ago by Don-vip

Keywords: cycleway bicycle oneway added

comment:2 Changed 12 months ago by evod

I would like to second this suggestion. According to the OSM Wiki simply tagging bicycle:oneway=no is sufficient.

Quote from https://wiki.openstreetmap.org/wiki/Key:oneway#oneway_.3D_no:
"Oneway can be used in conjunction with vehicle type in order to tag exceptions. I.e. oneway:moped=no for a one-way streets where mopeds are allowed to drive in the opposite direction, oneway:bicycle=no for bicycles. cycleway=opposite/opposite_lane/opposite_track may be additionally added to clarify bicycle infrastructure and to increase compatibility"

comment:3 Changed 10 months ago by skyper

Ticket #18626 has been marked as a duplicate of this ticket.

comment:4 Changed 10 months ago by Emvee

Like written in #18626:

cycleway=opposite is slowly but steadily becoming deprecated in favor of oneway:bicycle=yes, see the graph on ​https://wiki.openstreetmap.org/wiki/Talk:Key:oneway:bicycle#This_key_and_cycleway.3Dopposite

So if it is difficult to change elemstyles.mapcss so that both cycleway=opposite and oneway:bicycle=no provide rendering to indicate bidirectional access for cyclists then doing it for oneway:bicycle=no instead of cycleway=opposite would make sense.

comment:5 Changed 10 months ago by Klumbumbus

Milestone: 20.02

comment:6 Changed 10 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 15829/josm:

Fix #17820 - Same support for oneway:bicycle=no as for cycleway=opposite

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.