Modify

Opened 17 months ago

Closed 3 weeks ago

Last modified 3 weeks ago

#17809 closed enhancement (wontfix)

convert FIXME=* to fixme=*

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report fixme Cc:

Description (last modified by mkoniecz)

What steps will reproduce the problem?

  1. tag node with FIXME=geometry and building=hangar
  2. run validator

What is the expected result?

Validator offer to change FIXME=geometry to fixme=geometry to help eleiminate FIXME duplicating fixme tag.

What happens instead?

Validator is not proposing tag changes.

Please provide any additional information below. Attach a screenshot if possible.

I can implement this, after confirmation that it would not be rejected.

See equivalent iD issue at https://github.com/openstreetmap/iD/issues/6477

@matkoniecz Thanks for the links! I'm glad this was already discussed since it saves us time. I read through the mailing list discussion and it convinced me that we should definitely deprecate FIXME in iD. Most people agreed that FIXME is dated and wrong. Another developer even mentioned how FIXME caused them hours of extra work. The disagreements concerned the necessity and effectiveness of the edit. Responding to the primary arguments I saw against your bot edit:

FIXME should purposely cause validator tools to flag it by being all capitalized.

A validator tool doesn't need special capitalization to flag something. In fact, having two tags makes it more likely that a validator will miss a fixme.

Fixmes aren't important enough to create new entity versions over.

Users would manually be updating features in iD, so I think creating new versions is warranted.

A single bot edit won't prevent future uses of FIXME. Editors should handle this.

This is the part we can address!

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-06-12 22:04:53 +0200 (Wed, 12 Jun 2019)
Build-Date:2019-06-13 01:30:52
Revision:15169
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15169 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 423 MB / 869 MB (185 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34977)
+ PicLayer (35030)
+ buildings_tools (34982)
+ continuosDownload (82)
+ ejml (34908)
+ geotools (34908)
+ imagery_offset_db (34908)
+ jts (34908)
+ log4j (34908)
+ measurement (34977)
+ reverter (34999)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: java.net.SocketTimeoutException: connect timed out
- E: java.net.SocketTimeoutException: connect timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: connect timed out
- E: IO Exception - org.openstreetmap.josm.gui.widgets.HtmlPanel[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: java.net.SocketTimeoutException: connect timed out
- W: Already here java.net.SocketTimeoutException: connect timed out
- E: java.net.SocketTimeoutException: connect timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: connect timed out
- E: IO Exception - org.openstreetmap.josm.gui.widgets.HtmlPanel[,0,0,0x0,invalid,layout=java.awt.BorderLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]

Attachments (0)

Change History (9)

comment:1 Changed 17 months ago by mkoniecz

Description: modified (diff)

comment:2 Changed 17 months ago by Don-vip

Keywords: fixme added

comment:3 in reply to:  description Changed 17 months ago by Don-vip

Replying to mkoniecz:

I can implement this, after confirmation that it would not be rejected.

I agree with the change.

comment:4 Changed 17 months ago by Klumbumbus

I'm OK with that too. Fixme and other occurrences of FIXME:* should be flagged too: taginfo:search?q=fixme. Translated string in TagChecker.java containing "FIXME" should be changed too.

Last edited 3 weeks ago by Klumbumbus (previous) (diff)

comment:5 Changed 16 months ago by skyper

One advantage of FIXME or Fixme is that it appears at the top of the list.

I use FIXME because it even better highlights and if you have ways with 20 tags you often do not spot the fixme tag among the others.

Please, open a bigger discussion before changing this key automatically, and at least somehow highlight fixme better in the list. - Thanks

comment:6 in reply to:  5 Changed 16 months ago by skyper

Replying to skyper:

One advantage of FIXME or Fixme is that it appears at the top of the list.

I use FIXME because it even better highlights and if you have ways with 20 tags you often do not spot the fixme tag among the others.

Please, open a bigger discussion before changing this key automatically, and at least somehow highlight fixme better in the list. - Thanks

Sorry forgot two points:

  • FIXME=* is mentioned as alternative on the wiki page.
  • As taginfo stats we are talking about 185000 objects (~13% of "fixme") at the moment.

comment:7 Changed 9 months ago by skyper

Discussion from 2018: https://lists.openstreetmap.org/pipermail/talk/2018-July/thread.html#80916

How are the numbers compared to imports vs normal edits ?

comment:8 Changed 3 weeks ago by Klumbumbus

In 17153/josm:

see #17809 - Don't promote spelling FIXME, deprecate Fixme in favor of fixme

comment:9 Changed 3 weeks ago by Klumbumbus

Resolution: wontfix
Status: newclosed

For several reasons mentioned it is not useful to change FIXME tags to fixme:

  • FIXME=* is mentioned as alternative on the wiki page.
  • currently 215000 objects use FIXME
  • changing only FIXME to fixme doesn't improve the data, they should better be fixed actually
  • we have the info-warning for fixme case insensitive
  • we now have the warning from #17296 which might help to reduce the number of fixmes a bit
Last edited 3 weeks ago by Klumbumbus (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.