Modify

Opened 4 years ago

Closed 4 years ago

#17734 closed defect (duplicate)

JAXB not found with Java 11 when loading a TCX file

Reported by: hopet@… Owned by: team
Priority: normal Milestone:
Component: Plugin dataimport Version:
Keywords: template_report java11 jaxb tcx Cc:

Description

What steps will reproduce the problem?

  1. Enabled dataimport plugin
  2. Tried to open a TCX file (downloaded from Garmin Connect)

What is the expected result?

Opened trace like with GPX files.

What happens instead?

Exception.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-28 04:36:41 +0200 (Sun, 28 Apr 2019)
Revision:15031
Build-Date:2019-04-28 02:37:58
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15031 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1809 (17763)
Memory Usage: 634 MB / 4052 MB (123 MB allocated, but free)
Java version: 11.0.1+13-LTS, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 3840x2160
Maximum Screen Size: 3840x2160
VM arguments: [-Djava.net.preferIPv4Stack=true, -Dsun.java2d.uiScale=1.5]

Plugins:
+ CommandLine (34977)
+ DirectDownload (34977)
+ DirectUpload (34908)
+ ElevationProfile (34977)
+ FastDraw (34977)
+ ImportImagePlugin (34908)
+ InfoMode (34908)
+ OpenStreetCam (236)
+ OpeningHoursEditor (34977)
+ PicLayer (34389)
+ SimplifyArea (34977)
+ Tracer-testing (1556034991)
+ alignways (34977)
+ apache-commons (34908)
+ areaselector (349)
+ austriaaddresshelper (57)
+ buildings_tools (34982)
+ contourmerge (v0.1.4)
+ dataimport (34908)
+ editgpx (34908)
+ ejml (34908)
+ ext_tools (34988)
+ geotools (34908)
+ gpsblam (34908)
+ gpxfilter (34908)
+ gson (34908)
+ imagery_offset_db (34908)
+ jaxb (34908)
+ jts (34908)
+ log4j (34908)
+ mapdust (${version.entry.commit.revision})
+ measurement (34977)
+ merge-overlap (34972)
+ opendata (34997)
+ openvisible (34908)
+ photo_geotagging (34908)
+ pointInfo (34908)
+ reverter (34999)
+ routes (34908)
+ terracer (34977)
+ todo (30306)
+ turnlanes (34994)
+ turnrestrictions (34977)
+ utilsplugin2 (34977)
+ waydownloader (34977)
+ wikipedia (v1.1.1)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountainbike&preset&zip=1
+ http://osmtools.de/josm/steps.xml
+ http://dev.openseamap.org/josm/Presets_Sport.xml
+ c:\Users\<user.name>\AppData\Roaming\JOSM\plugins\<user.name>-presets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MountainbikeTrails&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Czech_hiking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/geoimage.at&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/CZ.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Czech_Slovak_addresses&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Mountains&zip=1

Last errors/warnings:
- E: Failed to locate image 'http://www.dstoecker.eu/josm/oneclick.png'
- E: Failed to locate image 'http://www.dstoecker.eu/josm/oneway.png'
- W:  One click: Could not get presets icon http://www.dstoecker.eu/josm/oneclick.png
- W: [NODE] Fixme-continues: Could not get presets icon http://www.dstoecker.eu/josm/oneway.png
- W: javax.imageio.IIOException: Caught exception during read:. Cause: java.lang.ArrayIndexOutOfBoundsException: Index 1 out of bounds for length 1
- E: Failed to locate image 'traffic_signs_presets/tunnel.png'
- W:  Tunnel: Could not get presets icon traffic_signs_presets/tunnel.png
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.RuntimeException: javax.xml.bind.JAXBException: Implementation of JAXB-API has not been found on module path or classpath.
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>apache-commons</li><li>geotools</li><li>opendata</li><li>SimplifyArea</li><li>dataimport</li><li>alignways</li><li>measurement</li><li>OpenStreetCam</li><li>jaxb</li><li>routes</li><li>editgpx</li><li>utilsplugin2</li><li>terracer</li><li>turnrestrictions</li><li>wikipedia</li><li>PicLayer</li><li>contourmerge</li><li>log4j</li><li>imagery_offset_db</li><li>InfoMode</li><li>gpsblam</li><li>pointInfo</li><li>ElevationProfile</li><li>gpxfilter</li><li>jts</li><li>mapdust</li><li>DirectDownload</li><li>DirectUpload</li><li>ejml</li><li>turnlanes</li><li>reverter</li><li>Tracer-testing</li><li>FastDraw</li><li>ext_tools</li><li>todo</li><li>CommandLine</li><li>openvisible</li><li>photo_geotagging</li><li>ImportImagePlugin</li><li>OpeningHoursEditor</li><li>areaselector</li><li>buildings_tools</li><li>gson</li><li>austriaaddresshelper</li><li>waydownloader</li><li>merge-overlap</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (64) of main
java.lang.RuntimeException: javax.xml.bind.JAXBException: Implementation of JAXB-API has not been found on module path or classpath.
 - with linked exception:
[java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory]
	at org.openstreetmap.josm.plugins.dataimport.io.Tcx.parseFile(Tcx.java:108)
	at org.openstreetmap.josm.plugins.dataimport.io.Tcx.importData(Tcx.java:72)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:367)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:319)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: javax.xml.bind.JAXBException: Implementation of JAXB-API has not been found on module path or classpath.
 - with linked exception:
[java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory]
	at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:278)
	at javax.xml.bind.ContextFinder.find(ContextFinder.java:421)
	at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:721)
	at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:662)
	at org.openstreetmap.josm.plugins.dataimport.io.Tcx.parseFile(Tcx.java:92)
	... 11 more
Caused by: java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	at javax.xml.bind.ServiceLoaderUtil.nullSafeLoadClass(ServiceLoaderUtil.java:122)
	at javax.xml.bind.ServiceLoaderUtil.safeLoadClass(ServiceLoaderUtil.java:155)
	at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:276)
	... 15 more

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin dataimport
Keywords: java11 jaxb tcx added
Summary: Crash in dataimport pluginJAXB not found with Java 11 when loading a TCX file

comment:2 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17152.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.