Modify

Opened 11 months ago

Closed 10 months ago

Last modified 8 months ago

#17735 closed defect (duplicate)

IAE: Relation is already deleted (Deleting a boundary relation)

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report relation selection Cc: hilaryjosm@…

Description

What steps will reproduce the problem?

  1. I attempted to delete the boundary relation for Sanday (2430896) by selecting one of its members and choosing "Select relation" and then "Delete" from the menu over the relation. (I was deleting it because there was also a multipolygon for the same members and the other islands in the Orkneys do not appear to have boundary relations for the individual islands)
  2. The relation stayed visible in the Selection part of the window, so I assumed I had not deleted it properly, and tried "Delete" again from menu over it
  3. JOSM told me there was a bug.

(I will undo, if it allows me, and leave the relation existing)

What is the expected result?

I would have expected the relation to disappear from the JOSM window.

What happens instead?

It didn't disappear.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-28 04:36:41 +0200 (Sun, 28 Apr 2019)
Build-Date:2019-04-28 02:37:58
Revision:15031
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15031 en_GB) Linux Mint 17.3 Rosa
Memory Usage: 546 MB / 1820 MB (92 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800
VM arguments: [-Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.tk=awt, -Djnlpx.jvm=${JAVA_HOME}/jre/bin/java, -Djnlpx.splashport=58104, -Djnlpx.home=${JAVA_HOME}/jre/bin, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=/tmp/session885408559920391495, -Djnlpx.heapsize=-1,2147483648, -Djava.security.policy=file:${JAVA_HOME}/jre/lib/security/javaws.policy, -DtrustProxy=true, -Djnlpx.origFilenameArg=${HOME}/.java/deployment/cache/6.0/56/1ee8cfb8-78b8e4ef, -Dsun.awt.warmup=true, -Djava.security.manager]
Dataset consistency test: No problems found

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Relation id=2430896 version=4 MVDT]} is already deleted


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-2 (48) of javawsApplicationThreadGroup
java.lang.IllegalArgumentException: {Relation id=2430896 version=4 MVDT]} is already deleted
	at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:191)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:301)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:355)
	at org.openstreetmap.josm.actions.mapmode.DeleteAction.deleteRelations(DeleteAction.java:358)
	at org.openstreetmap.josm.actions.relation.DeleteRelationsAction.deleteRelation(DeleteRelationsAction.java:38)
	at org.openstreetmap.josm.actions.relation.DeleteRelationsAction.actionPerformed(DeleteRelationsAction.java:49)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:842)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:886)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6539)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476)
	at java.awt.Container.dispatchEventImpl(Container.java:2283)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (6)

comment:1 Changed 11 months ago by anonymous

Component: Coreunspecified

comment:2 Changed 11 months ago by Hilary Phillips <hilaryjosm@…>

Cc: hilaryjosm@… added

comment:3 Changed 10 months ago by Don-vip

Summary: Deleting a boundary relation causes a bugIAE: Relation is already deleted (Deleting a boundary relation)

comment:4 Changed 10 months ago by Don-vip

Keywords: relation selection added
Milestone: 19.05

comment:5 Changed 10 months ago by Don-vip

Milestone: 19.05
Resolution: duplicate
Status: newclosed

Closed as duplicate of #15030.

comment:6 Changed 8 months ago by skyper

Component: unspecifiedCore

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.