Modify

Opened 10 months ago

Closed 5 months ago

#17152 closed defect (fixed)

ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory

Reported by: anonymous Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin dataimport Version:
Keywords: template_report jaxb java10 java11 Cc:

Description

What steps will reproduce the problem?

  1. start josm
  2. try to open garmin tcx
  3. Error

What is the expected result?

open tcx and show route

What happens instead?

error

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-11-28 01:09:01 +0100 (Wed, 28 Nov 2018)
Revision:14460
Build-Date:2018-11-28 00:26:41
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (14460 de) Linux Ubuntu 18.04.1 LTS
Memory Usage: 880 MB / 8042 MB (503 MB allocated, but free)
Java version: 10.0.2+13-Ubuntu-1ubuntu0.18.04.4, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 2560x1440
Maximum Screen Size: 2560x1440
Java package: openjdk-11-jre:amd64-10.0.2+13-1ubuntu0.18.04.4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ dataimport (34749)
+ jaxb (34506)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.RuntimeException: javax.xml.bind.JAXBException: Implementation of JAXB-API has not been found on module path or classpath.
- W: Achtung - <html>JOSM konnte keine Informationen über die folgenden Erweiterungen finden:<ul><li>jaxb</li><li>dataimport</li></ul>Diese Erweiterungen werden nicht geladen.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (64) of main
java.lang.RuntimeException: javax.xml.bind.JAXBException: Implementation of JAXB-API has not been found on module path or classpath.
 - with linked exception:
[java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory]
	at org.openstreetmap.josm.plugins.dataimport.io.Tcx.parseFile(Tcx.java:108)
	at org.openstreetmap.josm.plugins.dataimport.io.Tcx.importData(Tcx.java:72)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:367)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:291)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:95)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:143)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:514)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1135)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
	at java.base/java.lang.Thread.run(Thread.java:844)
Caused by: javax.xml.bind.JAXBException: Implementation of JAXB-API has not been found on module path or classpath.
 - with linked exception:
[java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory]
	at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:278)
	at javax.xml.bind.ContextFinder.find(ContextFinder.java:421)
	at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:721)
	at javax.xml.bind.JAXBContext.newInstance(JAXBContext.java:662)
	at org.openstreetmap.josm.plugins.dataimport.io.Tcx.parseFile(Tcx.java:92)
	... 11 more
Caused by: java.lang.ClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:583)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
	at javax.xml.bind.ServiceLoaderUtil.nullSafeLoadClass(ServiceLoaderUtil.java:122)
	at javax.xml.bind.ServiceLoaderUtil.safeLoadClass(ServiceLoaderUtil.java:155)
	at javax.xml.bind.ContextFinder.newInstance(ContextFinder.java:276)
	... 15 more

Attachments (0)

Change History (5)

comment:1 Changed 10 months ago by Don-vip

Component: CorePlugin dataimport
Keywords: jaxb java10 added

comment:2 Changed 10 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned
Summary: tcx import dont workClassNotFoundException: com.sun.xml.internal.bind.v2.ContextFactory

comment:3 Changed 5 months ago by Don-vip

Ticket #17734 has been marked as a duplicate of this ticket.

comment:4 Changed 5 months ago by Don-vip

Keywords: java11 added

comment:5 Changed 5 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o35010:35015].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.