Modify

Opened 4 years ago

Closed 3 years ago

#17590 closed enhancement (duplicate)

Detect missing oneway:bicycle

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report oneway bicycle Cc:

Description

What steps will reproduce the problem?

  1. Create line
  2. Add highway=residential + cycleway=opposite (or cycleway=opposite_lane) + oneway=yes + name=adherents_or_other_random_text
  3. Run validator

What is the expected result?

Validator requests to add oneway:bicycle. With value no (for typical cases, nearly 100%) or oneway:bicycle=yes (for extremely rare cases of contraflow lane or some other signage but bicycles still unable to legally drive in both directions) or oneway:biycle=-1 for road oneway for bicycles but in a different direction than for cars.

Given this rare exception fully automatic autofix may be unsuitable, but given that this cases happen very rarely I think that add message like "it is likely that oneway:bicycle=no is missing. This tag indicates that this road is not oneway for cyclists" not mentioning oneway:bicycle=yes and oneway:bicycle=-1 would be OK.

What happens instead?

Nothing.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-04-03 00:33:43 +0200 (Wed, 03 Apr 2019)
Build-Date:2019-04-03 01:30:50
Revision:14954
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14954 en) Linux Ubuntu 16.04.6 LTS
Memory Usage: 403 MB / 869 MB (176 MB allocated, but free)
Java version: 1.8.0_201-b09, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34867)
+ buildings_tools (34904)
+ continuosDownload (82)
+ imagery_offset_db (34867)
+ measurement (34867)
+ reverter (34961)
+ todo (30306)

Validator rules:
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/deprecated.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss
+ ${HOME}/Documents/install_moje/OSM software/josm/data/validator/combinations.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Failed to add ${HOME}/Documents/install_moje/OSM software/josm/data/validator/unnecessary.mapcss to tag checker
- W: java.lang.IllegalArgumentException: Expecting n/node/w/way/r/relation/area, but got '"node'

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Don-vip

Keywords: oneway bicycle added

comment:2 Changed 3 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9296.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.