Modify

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#17591 closed defect (fixed)

Zoom to download doesn't work as expected

Reported by: GerdP Owned by: team
Priority: normal Milestone: 19.04
Component: Core Version:
Keywords: regression Cc: Don-vip, wiktorn

Description

From https://forum.openstreetmap.org/viewtopic.php?pid=745086#p745086:

Every time I download new data in JOSM, (File > Download data, or Ctrl+Shift+Down, and accepting the >default selecting which is the current viewport), then the maps zooms out, with the downloaded data only >covering the inner 50% of the new viewport. I have to zoom in once to go back to the previous view and >the actual extends of the downloaded data.

Also using 5 (Zoom to Download) zooms out too much making the actual download only cover 50%.>

Is this due to a combination of wrong settings?

I initially though this was some faulty HiDPI processing, but my screen is only 1920x1080 and set to 100% >scaling in Windows.

Using JOSM 14945, jPortable 1.8.0_201, Windows 10.

Attachments (2)

17591.patch (1.7 KB) - added by GerdP 6 months ago.
17591-scale-follow.patch (3.4 KB) - added by GerdP 6 months ago.

Download all attachments as: .zip

Change History (8)

Changed 6 months ago by GerdP

Attachment: 17591.patch added

comment:1 Changed 6 months ago by GerdP

I think there are two problems:
1) The checkbox "Zoom to downloaded data" looks like "Zoom to download" but the current implementation doesn't try to do the same.
I don't know if this is intended, it is at least confusing.
2) The implementation for 5 (Zoom to download) calls BoundingXYVisitor.enlargeBoundingBoxLogarithmically(). I think this should not happen. The attached patch addresses this problem.

comment:2 Changed 6 months ago by GerdP

Milestone: 19.04

I think problem 2) is a regression from r14628

comment:3 Changed 6 months ago by GerdP

Resolution: fixed
Status: newclosed

In 14985/josm:

fix #17591 Zoom to download doesn't work as expected
Partly revert changes from r14628: don't enlarge area for "Zoom to download" or "Zoom to downloaded data"

comment:4 Changed 6 months ago by GerdP

Resolution: fixed
Status: closedreopened

There is still an issue when a e.g. a Bing layer is already open and "Scale follows native resolution of this layer" is enabled in the layer list (which is it by default).

Changed 6 months ago by GerdP

Attachment: 17591-scale-follow.patch added

comment:5 Changed 6 months ago by GerdP

Cc: Don-vip wiktorn added

This 2nd patch implements a new preference zoom.scale-follow-native-resolution-at-load. The default is true which is the current behaviour: A new layer that implements NativeScaleLayer gets the flag "scale follows native resolution of this layer".
If set to false this doesn't happen, the user can still enable one layer of his choice.

If I hear no complains I'll commit this patch next monday.

Last edited 6 months ago by GerdP (previous) (diff)

comment:6 Changed 6 months ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 14993/josm:

fix #17591: Add new preference zoom.scale-follow-native-resolution-at-load

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.