Modify

#17301 closed defect (fixed)

IAE: "can't parse argument number: width" at AbstractTileSourceLayer.paintTileText

Reported by: anonymous Owned by: team
Priority: normal Milestone: 19.04
Component: Core imagery Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-02-02 21:01:18 +0100 (Sat, 02 Feb 2019)
Build-Date:2019-02-04 21:50:11
Revision:14760
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14760 en) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1709 (16299)
Memory Usage: 627 MB / 1820 MB (407 MB allocated, but free)
Java version: 1.8.0_192-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ imagery_offset_db (34867)
+ turnrestrictions (34867)

Last errors/warnings:
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: java.lang.NumberFormatException: For input string: "{width}"
- E: Handled by bug report queue: java.lang.IllegalArgumentException: can't parse argument number: width. Cause: java.lang.NumberFormatException: For input string: "width"


=== REPORTED CRASH DATA ===
AbstractTileSourceLayer$TileSourcePainter#doPaint:
 - graphics: MapViewGraphics [graphics=sun.java2d.SunGraphics2D[font=java.awt.Font[family=SansSerif,name=sansserif,style=bold,size=13],color=java.awt.Color[r=255,g=0,b=0]], mapView=org.openstreetmap.josm.gui.MapView[,0,76,1544x863,alignmentX=0.0,alignmentY=0.0,border=,flags=2,maximumSize=,minimumSize=java.awt.Dimension[width=10,height=0],preferredSize=], clipBounds=MapViewRectangle [p1=MapViewViewPoint [x=0.0, y=0.0], p2=MapViewViewPoint [x=1544.0, y=863.0]]]
 - tileSource: Qom
 - currentZoomLevel: 17

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalArgumentException: can't parse argument number: width
	at java.text.MessageFormat.makeFormat(Unknown Source)
	at java.text.MessageFormat.applyPattern(Unknown Source)
	at java.text.MessageFormat.<init>(Unknown Source)
	at java.text.MessageFormat.format(Unknown Source)
	at org.openstreetmap.josm.tools.I18n.format(I18n.java:143)
	at org.openstreetmap.josm.tools.I18n.tr(I18n.java:175)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.paintTileText(AbstractTileSourceLayer.java:1169)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.drawInViewArea(AbstractTileSourceLayer.java:1594)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.access$2600(AbstractTileSourceLayer.java:142)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.doPaint(AbstractTileSourceLayer.java:1923)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.paint(AbstractTileSourceLayer.java:1917)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:469)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:558)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:491)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JSplitPane.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JLayeredPane.paint(Unknown Source)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.NumberFormatException: For input string: "width"
	at java.lang.NumberFormatException.forInputString(Unknown Source)
	at java.lang.Integer.parseInt(Unknown Source)
	at java.lang.Integer.parseInt(Unknown Source)
	... 59 more

Attachments (0)

Change History (3)

comment:1 Changed 16 months ago by Don-vip

Component: CoreCore imagery
Summary: Just send this bug...IAE: "can't parse argument number: width" at AbstractTileSourceLayer.paintTileText

comment:2 Changed 13 months ago by Don-vip

Milestone: 19.04

comment:3 Changed 13 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 15030/josm:

fix #17301 - robustness to untranslatable error messages

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.