Modify

Opened 8 weeks ago

Closed 4 weeks ago

Last modified 2 days ago

#17035 closed enhancement (fixed)

Validator: Improve progress monitor

Reported by: GerdP Owned by: GerdP
Priority: normal Milestone: 18.12
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Run validator on a dataset containing many (> 10000) objects

What is the expected result?

Progress monitor should show two progess bars. One that counts the tests, another that counts the progress on the validated objects in a single test.

What happens instead?

  • Progress monitor shows no progress when a specific test takes long because it only shows the progress of the tests (although many tests call progressMonitor.worked(1) for each primitive).
  • Progress monitor shows the aftermath message "updating ignored errors" together with e.g. "Test 38/38: Starting Wrongly Ordered Ways" when the test "Wrongly Ordered Ways" is already done.

Please provide any additional information below. Attach a screenshot if possible.

Some tests might do complex calculations in the endTest() method. Those may need special treatment.

Build-Date:2018-11-27 09:20:37
Revision:14455
Is-Local-Build:true

Identification: JOSM/1.5 (14455 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1803 (17134)
Memory Usage: 1081 MB / 3641 MB (571 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:57084, -ea, -Dfile.encoding=UTF-8]
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34535)
+ apache-commons (34506)
+ buildings_tools (34724)
+ download_along (34503)
+ ejml (34389)
+ geotools (34513)
+ jaxb (34506)
+ jts (34524)
+ merge-overlap (34664)
+ o5m (34405)
+ opendata (34698)
+ pbf (34576)
+ poly (34546)
+ reverter (34552)
+ undelete (34568)
+ utilsplugin2 (34506)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Thread main-worker-0 raised org.openstreetmap.josm.gui.progress.ProgressException: Expected states are [INIT] but current state is IN_TASK

Attachments (2)

17035-progress-monitor.patch (3.1 KB) - added by GerdP 8 weeks ago.
17035-progress-monitor-v2.patch (2.6 KB) - added by GerdP 4 weeks ago.
updated to #14594

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 weeks ago by Klumbumbus

See also #13805

Changed 8 weeks ago by GerdP

comment:2 Changed 8 weeks ago by GerdP

Please review. A test can set a flag so that the progress monitor shows a count every 1000 elements.
This is a very simple solution but I think it works well enough.

comment:3 Changed 5 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

In 14563/josm:

(The changeset message doesn't reference this ticket)

comment:4 Changed 5 weeks ago by GerdP

Resolution: fixed
Status: closedreopened

Sorry for the typo. The fix was for #17036.

Changed 4 weeks ago by GerdP

updated to #14594

comment:5 Changed 4 weeks ago by GerdP

Oops, wrong link. I meant the patch is updated for r14594.
If I hear no complains I'll commit this tomorrow.
Adding a 2nd progress bar is too complex for me, besides the monitor is used in many places and in most of them it shows either no progress until it is removed or it shows a full bar and stays a bit because another action takes long.
Example for the latter: Open a large data file and search for all nodes. The search takes only fractions of a second but the update of the ToggleDialogs can take several seconds.

comment:6 Changed 4 weeks ago by GerdP

Resolution: fixed
Status: reopenedclosed

In 14599/josm:

fix #17035: Validator: Improve progress monitor (17035-progress-monitor-v2.patch)

  • Each test can enable a counter that shows "{0} of {1} elements done" for the tested OSM elements. The counter is increased in steps of 1000. For now this is only enabled for MapCSSTagChecker.
  • Don't show the name of the last executed test while postprocessing the results of all tests.

comment:7 Changed 2 days ago by Don-vip

Milestone: 18.12

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.