Modify

Opened 4 years ago

Closed 13 months ago

Last modified 12 months ago

#17034 closed enhancement (fixed)

Add support for power=connection

Reported by: Penegal Owned by: team
Priority: normal Milestone: 21.12
Component: Internal preset Version:
Keywords: power connection preset warning validation Cc: Gazer75

Description (last modified by Don-vip)

There happens that crossing power lines are connected with one another without any supporting pole or tower, such as on the attached picture. In this case, the lines share a node tagged power=connection, but JOSM has no support of this configuration: it has no such preset, and warns about power line nodes without power=(pole|tower). Could this preset be added and the relevant warning adapted to not show when the node is tagged power=connection?

Example of connections

Attachments (3)

Example.png (1020.6 KB) - added by Penegal 4 years ago.
Example of connections
photo-vs-other.png (25.9 KB) - added by Hb--- 3 years ago.
Power_connection.patch (14.5 KB) - added by gaben 13 months ago.
first idea

Download all attachments as: .zip

Change History (35)

Changed 4 years ago by Penegal

Attachment: Example.png added

Example of connections

comment:1 Changed 4 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 4 years ago by francois.lacombe

Nice one
power=connection haven't been reviewed yet.
It has been part of a huge (rejected) proposal in 2014 : https://wiki.openstreetmap.org/wiki/Proposed_features/Power_paths_refinement
Despite it is currently used about 1000 times, I'm not sure to add it as a preset.

Nevertheless, JOSM shouldn't warn users when two power=* lines connect each other.
The warning should raise if and only if the node is shared by both power and non-power objects or standalone in a single line.
We can find connection nodes with power=switch in substations for instance

Hope it helps

comment:3 Changed 4 years ago by Klumbumbus

Component: CoreInternal preset
Milestone: 18.12

comment:4 in reply to:  2 Changed 4 years ago by Klumbumbus

Replying to francois.lacombe:

I'm not sure to add it as a preset.

Is there a reason? The tag seems fine to me.

comment:5 Changed 4 years ago by francois.lacombe

It is not currently documented on wiki.
Despite the idea sounds good, if there is no connection, then there should be no shared node between nodes.
connection=* (especially connection=no) is find to say that several lines sharing the same pole aren't connected.
Additional design should be done with those two tags.

I fully agree on the warning anyway

comment:6 Changed 4 years ago by Klumbumbus

Milestone: 18.1219.01

comment:7 Changed 4 years ago by Don-vip

Milestone: 19.0119.02

comment:8 Changed 4 years ago by Don-vip

Milestone: 19.0219.03

comment:9 Changed 4 years ago by Klumbumbus

Milestone: 19.0319.04

comment:10 Changed 4 years ago by Don-vip

Milestone: 19.0419.05

comment:11 Changed 4 years ago by Klumbumbus

In 15088/josm:

  • see #17034 - add icon proposals for connection nodes of power lines
  • add svn:mime-type of images

comment:12 Changed 4 years ago by Klumbumbus

Milestone: 19.05

Removing the milestone as first power=conection vs. connection=yes/no should be decided (not in this ticket).
I added 3 possible icons for later use to the nodist folder:
source:/trunk/nodist/images/presets/power_connection1.svg source:/trunk/nodist/images/presets/power_connection2.svg source:/trunk/nodist/images/presets/power_connection3.svg

Last edited 14 months ago by skyper (previous) (diff)

comment:13 Changed 4 years ago by francois.lacombe

Thank you Klumbumbus

I'd be in favour of 3rd icon from your proposal
First two, with straight connections may let mapper think they refer to bundles link like here : https://wiki.openstreetmap.org/wiki/File:JP_Power_Wires_Fivefold.JPG

Regarding power=connection vs connection=* I think both should be valid, depending on the previous usage of power=* for another value (like poles)

comment:14 in reply to:  11 Changed 3 years ago by Hb---

Replying to Klumbumbus:

In 15088/josm: ... add svn:mime-type of images

Please check images/data/imagery/photo.svg again. This icon needs 80% of the help browser screen and is currently not seen in the Imagery menu. The other svg images are also very larrge in the help browser.

comment:15 Changed 3 years ago by Klumbumbus

Thats not related to this ticket. It is #15864.

Changed 3 years ago by Hb---

Attachment: photo-vs-other.png added

comment:16 Changed 3 years ago by Hb---

Comment 14 was not about the general issue, but only for some svg images which were changed last with r15088. They were initally uplodated for #16301 with r15049. Opening a new ticket seemed inappropriate.

Most oversized one is photo.svg, see screenshot. The osmbasedmap.svg seems also to large.

comment:17 Changed 14 months ago by skyper

numbers are still low resp. minimal for power=connection and connection=*

Regarding power=connection my major concern is the missing wiki page.

comment:18 in reply to:  17 Changed 13 months ago by harahu

Replying to skyper:

Regarding power=connection my major concern is the missing wiki page.

See: https://wiki.openstreetmap.org/wiki/Tag:power%3Dconnection

comment:19 Changed 13 months ago by Klumbumbus

Ticket #21566 has been marked as a duplicate of this ticket.

comment:20 Changed 13 months ago by Klumbumbus

Cc: Gazer75 added

comment:21 Changed 13 months ago by Klumbumbus

I'm in favor of adding power=connection now. The wiki page is present and the number grows constantly. connection=* on the other hand has still a very low count.
I can do the peset and mappaint part, but someone else needs to adapt the validator test (i.e. don't warn about power=connection on power intersection nodes and adapt the warning message). This also interferes with the patch in #20716.

comment:22 Changed 13 months ago by skyper

I think fixing the validator only requires to add connection to either POWER_TOWER_TAGS or POWER_ALLOWED_TAGS.

comment:23 Changed 13 months ago by GerdP

gaben is working on a larger patch for PowerLines, see #20716

comment:24 in reply to:  22 Changed 13 months ago by harahu

Replying to skyper:

I think fixing the validator only requires to add connection to either POWER_TOWER_TAGS or POWER_ALLOWED_TAGS.

I haven't looked at the code, so can't say whether what you suggest will have the desired effect or not, but I see some potential pitfalls to keep in mind.

One is that power=connection likely shouldn't be considered on par with tower or pole in all situations. For instance, it makes little sense on a single line. My understanding of the tag is that is should exclusively be present on line crossings.

So, if you replace a power=tower with a power=connection on a single line, that should probably raise a warning.

This would have the added benefit of catching issues caused by having a valid line crossing with a connection and then deleting one of the connected lines.

comment:25 in reply to:  22 ; Changed 13 months ago by gaben

I removed most false warnings for power=connection in the validator, that's all for now. No patch yet. What else is needed?

comment:26 in reply to:  25 Changed 13 months ago by Klumbumbus

Replying to gaben:

What else is needed?

I'm not sure whats best to commit it before, together of after #20716.

comment:27 Changed 13 months ago by gaben

Can be done before, as just adding the "connection" string here silences the "Missing power tower/pole within power line" warning.

  • src/org/openstreetmap/josm/data/validation/tests/PowerLines.java

     
    4444    static final Collection<String> BUILDING_STATION_TAGS = Arrays.asList("transformer_tower");
    4545    /** Values for {@code power} key interpreted as allowed power items */
    4646    static final Collection<String> POWER_ALLOWED_TAGS = Arrays.asList("switch", "transformer", "busbar", "generator", "switchgear",
    47             "portal", "terminal", "insulator");
     47            "portal", "terminal", "insulator", "connection");
    4848
    4949    private final Set<Node> badConnections = new LinkedHashSet<>();
    5050    private final Set<Node> missingTowerOrPole = new LinkedHashSet<>();

comment:28 Changed 13 months ago by Klumbumbus

Milestone: 21.11

Changed 13 months ago by gaben

Attachment: Power_connection.patch added

first idea

comment:29 in reply to:  12 Changed 13 months ago by gaben

source:/trunk/nodist/images/presets/power_connection1.svg source:/trunk/nodist/images/presets/power_connection2.svg source:/trunk/nodist/images/presets/power_connection3.svg

The initial patch contains the 3rd version and includes the operator tag which may be unnecessary. Also, an SVG cleanup is needed I think.

comment:30 Changed 13 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 18324/josm:

fix #17034 - Add power=connection (partly patch by gaben, icon self created PD and CC0 licensed)

comment:31 Changed 13 months ago by gaben

Ah nothing, please ignore.

Last edited 13 months ago by gaben (previous) (diff)

comment:32 Changed 12 months ago by Don-vip

Milestone: 21.1121.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.