Modify

Opened 3 weeks ago

Closed 3 weeks ago

#16908 closed defect (fixed)

FontsManager prevents JOSM to start when local disk is full

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 18.10
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

JOSM starts

What happens instead?

Error, maybe it was some kind of canceling an upload to OSM before closing JOSM the time before the error occurred with starting JOSM

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-01 23:59:36 +0200 (Mon, 01 Oct 2018)
Build-Date:2018-10-01 22:08:47
Revision:14289
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14289 de) Linux Ubuntu 16.04.5 LTS
Memory Usage: 150 MB / 1749 MB (126 MB allocated, but free)
Java version: 1.8.0_181-8u181-b13-0ubuntu0.16.04.1-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u181-b13-0ubuntu0.16.04.1

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.IOException: Auf dem Gerät ist kein Speicherplatz mehr verfügbar. Ursache: java.io.IOException: Auf dem Gerät ist kein Speicherplatz mehr verfügbar


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.io.IOException: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
	at org.openstreetmap.josm.tools.FontsManager.initialize(FontsManager.java:43)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:809)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:283)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:710)
Caused by: java.io.IOException: Auf dem Gerät ist kein Speicherplatz mehr verfügbar
	at java.io.FileOutputStream.writeBytes(Native Method)
	at java.io.FileOutputStream.write(FileOutputStream.java:326)
	at java.awt.Font.createFont0(Font.java:952)
	at java.awt.Font.createFont(Font.java:877)
	at org.openstreetmap.josm.tools.FontsManager.initialize(FontsManager.java:41)
	... 3 more

Attachments (0)

Change History (4)

comment:1 Changed 3 weeks ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

If I translate "Auf dem Gerät ist kein Speicherplatz mehr verfügbar" correctly, I get "There is no more memory available on the device".

So likely your disk is full. Please check and close the ticket if that's the case (not a JOSM issue).

Last edited 3 weeks ago by Don-vip (previous) (diff)

comment:2 Changed 3 weeks ago by Don-vip

In 14382/josm:

see #16908 - make sure FontsManager does not prevent JOSM to start

comment:3 Changed 3 weeks ago by Don-vip

Summary: No start of JOSMFontsManager prevents JOSM to start when local disk is full

comment:4 Changed 3 weeks ago by Don-vip

Milestone: 18.10
Resolution: fixed
Status: needinfoclosed

This specific startup issue is fixed, but you will likely get a ton of other problems if your hard disk is full.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.