Opened 5 years ago

Closed 5 years ago

Last modified 2 years ago

#16847 closed defect (othersoftware)

Tooltips glitches

Reported by: lorenzo.beba@… Owned by: lorenzo.beba@…
Priority: normal Milestone:
Component: Core Version: tested
Keywords: tooltips, UI, user interface javabug Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Open JOSM for Windows (josm.jnlp, josm-tested.jar or Windows installer, it's the same)
  2. Hold the mouse anywhere to make a tooltip appear (especially in the relation edit panel with downloaded members)
  3. Move the mouse around to show much tooltips as possible (or wait enough, usually from 10 to 30 minutes of normal use)
  4. All the interface will be a mess of repeated UI

What is the expected result?

The UI should always be usable.

What happens instead?

JOSM must be restarted to be used again because the UI is repeated randomly in every window when you pass the cursor over a button.

Please provide any additional information below. Attach a screenshot if possible.

On Debian and Ubuntu everything works right, even on two others Windows 10 PC (one of which with a dual monitor too). I've already tried to purge and re-install Java and also JOSM (deleting all files under the AppData directory). I've tried also with a clean version of JOSM (fresh download, without adding plugins or styles), but the glitch always appears.

Glitch without aerial imagery

Glitch with aerial imagery

Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-01 23:59:36 +0200 (Mon, 01 Oct 2018)
Build-Date:2018-10-01 22:08:47
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14289 it) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 1803 (17134)
Memory Usage: 247 MB / 989 MB (129 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768, \Display1 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Map paint styles:

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (3)

2018-10-16 21_07_33-JOSM.png (270.6 KB) - added by Lorenzo Beltrami <lorenzo.beba@…> 5 years ago.
Glitch without aerial imagery
2018-10-12 22_14_47-JOSM.png (406.8 KB) - added by Lorenzo Beltrami <lorenzo.beba@…> 5 years ago.
Glitch with aerial imagery
DxDiag.txt (77.7 KB) - added by Lorenzo Beltrami <lorenzo.beba@…> 5 years ago.
DxDiag report

Download all attachments as: .zip

Change History (15)

Changed 5 years ago by Lorenzo Beltrami <lorenzo.beba@…>

Glitch without aerial imagery

Changed 5 years ago by Lorenzo Beltrami <lorenzo.beba@…>

Glitch with aerial imagery

comment:1 Changed 5 years ago by Don-vip

Keywords: javabug added

What's your graphic card and graphic driver version? It's not a JOSM bug but a rendering problem between Java and your graphics software/hardware.

comment:2 Changed 5 years ago by Don-vip

Owner: changed from team to lorenzo.beba@…
Status: newneedinfo

comment:3 Changed 5 years ago by Lorenzo Beltrami <lorenzo.beba@…>

Thanks for the help, I have an AMD Radeon HD 6700 Series chipset with 15.201.1151.1008-151104a-296217E Driver Packaging Version.

Are there any settings or workarounds I can use to fix it?

comment:4 Changed 5 years ago by Don-vip

That's an old GPU and I see AMD doesn't update its driver for it since 2015. Do you have more recent hardware on the two functional machines? Please attach your DxDiag report (run the "dxdiag" program then export the report using save button) and I'll report the issue to Oracle. Nothing more we can do.

Changed 5 years ago by Lorenzo Beltrami <lorenzo.beba@…>

Attachment: DxDiag.txt added

DxDiag report

comment:5 Changed 5 years ago by Lorenzo Beltrami <lorenzo.beba@…>

Until July I ran JOSM correctly on a dual boot Ubuntu on this same machine with this hardware (I don't rememeber with which driver). Now I tried JOSM on Debian in a VirtualBox VM (always on this machine) and it works correctly.

In addition I tried to update drivers and now it says they are at 15.20.1062.1004-150803a1-187674C Driver Packaging Version (is AMD continuing to release some maintenance updates?).

comment:6 Changed 5 years ago by Don-vip

No idea. Still the same problem with the new driver?

comment:7 Changed 5 years ago by Lorenzo Beltrami <lorenzo.beba@…>

Sorry, I forgot to write it: yes, same problem with the new driver.

comment:8 Changed 5 years ago by Don-vip

Bug report created. If accepted it will become available here.

I see nevertheless you're using a 32-bit JRE. Please uninstall it and install a 64-bit JRE instead. It might help.

comment:9 Changed 5 years ago by Don-vip

Resolution: othersoftware
Status: needinfoclosed

comment:10 Changed 5 years ago by Don-vip

Bug has been accepted: javabug:8213146

comment:11 Changed 4 years ago by Don-vip

Description: modified (diff)

similar problem in #18182

comment:12 Changed 2 years ago by nickvet419@…

I have the same issues

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain lorenzo.beba@….
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.