Modify

Opened 5 months ago

Closed 5 months ago

#16431 closed defect (fixed)

JOSM complains about what looks like weird but OK tagging

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.06
Component: Internal mappaint style Version:
Keywords: template_report parking Cc:

Description

What steps will reproduce the problem?

  1. validate https://www.openstreetmap.org/way/347558708

What is the expected result?

No complaints.

What happens instead?

Area style on outer way, caused by amenity=parking_space, capacity=4 on outer ways of multipolygon with amenity=parking.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-24 19:57:43 +0200 (Sun, 24 Jun 2018)
Build-Date:2018-06-24 18:08:53
Revision:13974
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13974 en) Linux Ubuntu 16.04.4 LTS
Memory Usage: 961 MB / 961 MB (308 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (34095)
+ buildings_tools (34212)
+ continuosDownload (1529090613)
+ imagery_offset_db (34337)
+ reverter (34271)
+ todo (30304)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " <IDENT> "way "" at line 222, column 1.

Attachments (0)

Change History (2)

comment:1 Changed 5 months ago by Don-vip

Component: Core validatorInternal mappaint style
Keywords: parking added
Milestone: 18.06

comment:2 Changed 5 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13979/josm:

fix #16431 - add small color difference when rendering amenity=parking and amenity=parking_space

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.