Modify

Opened 3 years ago

Last modified 11 months ago

#16395 reopened enhancement

Warning/test for possible wrong lanes count

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: oneway lanes lanes-tagging Cc:

Description

At https://josm.openstreetmap.de/ticket/8519#comment:22 we can see that JOSM has (or had?) a test for lanes >= lanes:forward + lanes:backward

But have a non-oneway way with highway=primary + lanes:forward=2 + lanes=2, for example, and validate it: we don't see any warning (while we should).

JOSM:

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-06-14 19:38:30 +0200 (Thu, 14 Jun 2018)
Revision:13932
Build-Date:2018-06-14 17:40:29
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13932 pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 308 MB / 5120 MB (143 MB allocated, but free)
Java version: 10.0.1+10-Debian-4, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-10-jre:amd64-10.0.1+10-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21
VM arguments: [--illegal-access=warn, --add-modules=java.se.ee, -Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (34109)
+ ImportImagePlugin (34219)
+ OpeningHoursEditor (34095)
+ PicLayer (34170)
+ SimplifyArea (34109)
+ apache-commons (34109)
+ areaselector (336)
+ austriaaddresshelper (1525848529)
+ buildings_tools (34212)
+ download_along (34081)
+ editgpx (34109)
+ ejml (34126)
+ geojson (80)
+ geotools (34125)
+ jogl (1.1.0)
+ jts (34038)
+ log4j (34038)
+ measurement (34109)
+ merge-overlap (34109)
+ opendata (34196)
+ photo_geotagging (34109)
+ poly (34098)
+ reverter (34271)
+ tageditor (34109)
+ todo (30304)
+ turnlanes-tagging (263)
+ turnrestrictions (34129)
+ undelete (34274)
+ utilsplugin2 (34286)
+ wikipedia (v1.0.1)

Attachments (0)

Change History (7)

comment:1 Changed 3 years ago by Don-vip

Keywords: lanes added
Resolution: invalid
Status: newclosed

The error is trigerred if lanes < lanes:forward+lanes:backward. So your example is valid (2 >= 2).

comment:2 Changed 3 years ago by naoliv

Resolution: invalid
Status: closedreopened

But the problem is that my example is about a wrong highway.
A highway that is not oneway can't have all its lanes to only one direction
If lanes=2 and !oneway it should be a highway with lanes:forward=1 + lanes:backward=1
Having lanes:forward=2 means that the highway is missing oneway=yes or that people messed the lanes:forward value.

comment:3 Changed 3 years ago by Don-vip

OK. If anyone finds the English wording for the error message I'm OK to implement it.

comment:4 Changed 14 months ago by Don-vip

Keywords: oneway forward backward added

comment:5 Changed 14 months ago by Don-vip

#18488 is related

comment:6 in reply to:  3 Changed 14 months ago by skyper

Replying to Don-vip:

OK. If anyone finds the English wording for the error message I'm OK to implement it.

Maybe:

  • Number of {0} is equal to {1} but no restriction in directions.
  • Number of {0} is equal to {1} without "oneway=yes".

comment:7 Changed 11 months ago by skyper

Keywords: lanes-tagging added; forward backward removed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to naoliv
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.