Modify

Opened 6 years ago

Closed 6 years ago

#16278 closed defect (duplicate)

An error is displayed at any time

Reported by: anonymous Owned by: jBeata
Priority: normal Milestone:
Component: Plugin mapdust Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Using the mapdust plugin

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-09 21:51:30 +0200 (Wed, 09 May 2018)
Build-Date:2018-05-10 01:33:33
Revision:13722
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13722 ja) Windows 10 64-Bit
OS Build number: Windows 10 Home 1709 (16299)
Memory Usage: 647 MB / 1797 MB (158 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1515942663)
+ FastDraw (34109)
+ OpeningHoursEditor (34095)
+ buildings_tools (34109)
+ continuosDownload (68)
+ ejml (34126)
+ gson (34038)
+ log4j (34038)
+ mapdust (34095)
+ merge-overlap (34109)
+ turnrestrictions (34129)
+ utilsplugin2 (34109)
+ wikipedia (34162)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/JP.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/JaNamigSample&zip=1
+ https://raw.githubusercontent.com/maripo/OSM_tree_preset/master/presets/japan.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
- W: 警告 - <html>JOSMが次のプラグインの情報を見つけられませんでした。<ul><li>mapdust</li><li>ejml</li><li>FastDraw</li><li>continuosDownload</li><li>utilsplugin2</li><li>EasyPresets</li><li>OpeningHoursEditor</li><li>buildings_tools</li><li>gson</li><li>turnrestrictions</li><li>wikipedia</li><li>log4j</li><li>merge-overlap</li></ul>プラグインはロードされません。</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
	at org.openstreetmap.josm.gui.layer.Layer.destroy(Layer.java:301)
	at org.openstreetmap.josm.plugins.mapdust.MapdustPlugin.updateView(MapdustPlugin.java:598)
	at org.openstreetmap.josm.plugins.mapdust.MapdustPlugin$2.run(MapdustPlugin.java:563)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 by Klumbumbus, 6 years ago

Component: CorePlugin mapdust
Owner: changed from team to jBeata

comment:2 by Klumbumbus, 6 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14963.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.