Modify

#14963 closed defect (fixed)

IllegalStateException: The layer has already been destroyed: MapdustLayer

Reported by: okkarator@… Owned by: jBeata
Priority: normal Milestone:
Component: Plugin mapdust Version: latest
Keywords: template_report Cc: mpasha

Description

What steps will reproduce the problem?

  1. start josm
  2. download an small area (about 200x100m)
  3. zommed in
  4. -> failure

What is the expected result?

nothing special, just download an small map-area and zoomed in

What happens instead?

nothing special too. I zoomed in and die bug-window appeared

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-05-29 16:19:58 +0200 (Mon, 29 May 2017)
Build-Date:2017-05-29 14:25:03
Revision:12275
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12275 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 192 MB / 989 MB (49 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1200
Maximum Screen Size: 1920x1200
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (1010)
+ HouseNumberTaggingTool (33160)
+ PicLayer (33385)
+ gson (32680)
+ indoorhelper (33088)
+ mapdust (33232)
+ measurement (33088)
+ terracer (33088)
+ turnrestrictions (33088)

Map paint styles:
+ <josm.pref>\styles\indoor.mapcss

Validator rules:
- <josm.pref>\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- E: Handled by bug report queue: java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalStateException: The layer has already been destroyed: MapdustLayer [name=MapDust, associatedFile=null]
	at org.openstreetmap.josm.gui.layer.Layer.destroy(Layer.java:301)
	at org.openstreetmap.josm.plugins.mapdust.MapdustPlugin.updateView(MapdustPlugin.java:600)
	at org.openstreetmap.josm.plugins.mapdust.MapdustPlugin$2.run(MapdustPlugin.java:563)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

Screenshot 2017-06-24 13.25.38.png (723.8 KB) - added by okkarator@… 22 months ago.
screenshot of josm and the open bug-windows (failure report)

Download all attachments as: .zip

Change History (12)

Changed 22 months ago by okkarator@…

screenshot of josm and the open bug-windows (failure report)

comment:1 Changed 22 months ago by okkarator@…

I played a litte with JOSM and the problem is clearly to zoom in or out! It doesn't depend on if I use my mouse's scrolling-wheel or the keys "+" or "-".

comment:2 Changed 22 months ago by Klumbumbus

Component: CorePlugin mapdust
Owner: changed from team to jBeata

comment:3 Changed 21 months ago by Don-vip

Summary: unerwartete AusnahmeIllegalStateException: The layer has already been destroyed: MapdustLayer

comment:4 Changed 21 months ago by Don-vip

Ticket #15093 has been marked as a duplicate of this ticket.

comment:5 Changed 18 months ago by Don-vip

Ticket #15440 has been marked as a duplicate of this ticket.

comment:6 Changed 12 months ago by Klumbumbus

Ticket #16210 has been marked as a duplicate of this ticket.

comment:7 Changed 12 months ago by Klumbumbus

Cc: mpasha added

comment:8 Changed 12 months ago by Klumbumbus

Ticket #16278 has been marked as a duplicate of this ticket.

comment:9 Changed 12 months ago by Klumbumbus

Ticket #16279 has been marked as a duplicate of this ticket.

comment:10 Changed 11 months ago by Klumbumbus

Ticket #16306 has been marked as a duplicate of this ticket.

comment:11 Changed 11 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o34214:34215].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.