Modify

Opened 6 months ago

Closed 6 months ago

Last modified 5 months ago

#16277 closed defect (fixed)

Random error after switching between windows

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone: 18.05
Component: Core imagery Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-06 23:56:40 +0200 (Sun, 06 May 2018)
Build-Date:2018-05-06 21:59:07
Revision:13710
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13710 sv) null 32-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 1583 MB / 1796 MB (472 MB allocated, but free)
Java version: null, null, null
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ FastDraw (34109)
+ HouseNumberTaggingTool (34109)
+ OpeningHoursEditor (34095)
+ apache-commons (34109)
+ ejml (34126)
+ geotools (34125)
+ imagery_offset_db (34109)
+ jts (34038)
+ opendata (34153)
+ osm-obj-info (1509723997)
+ terracer (34109)
+ utilsplugin2 (34109)
+ wikipedia (34162)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Last errors/warnings:
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "user.home" "read")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "user.name" "read")
- E: Unable to get system env: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.JAVA_HOME")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "java.home" "read")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "user.home" "read")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "user.name" "read")
- E: Unable to get system env: java.security.AccessControlException: access denied ("java.lang.RuntimePermission" "getenv.JAVA_HOME")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "java.home" "read")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "user.home" "read")
- E: Unable to get system property: java.security.AccessControlException: access denied ("java.util.PropertyPermission" "user.name" "read")


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: WMS-downloader-31 (1721)
java.lang.SecurityException: Unable to create temporary file or directory
	at java.nio.file.TempFileHelper.create(Unknown Source)
	at java.nio.file.TempFileHelper.createTempFile(Unknown Source)
	at java.nio.file.Files.createTempFile(Unknown Source)
	at javax.imageio.stream.FileCacheImageInputStream.<init>(Unknown Source)
	at com.sun.imageio.spi.InputStreamImageInputStreamSpi.createInputStreamInstance(Unknown Source)
	at javax.imageio.ImageIO.createImageInputStream(Unknown Source)
	at javax.imageio.ImageIO.read(Unknown Source)
	at org.openstreetmap.gui.jmapviewer.Tile.loadImage(Tile.java:246)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.tryLoadTileImage(TMSCachedTileLoaderJob.java:278)
	at org.openstreetmap.josm.data.imagery.TMSCachedTileLoaderJob.loadingFinished(TMSCachedTileLoaderJob.java:189)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.finishLoading(JCSCachedTileLoaderJob.java:269)
	at org.openstreetmap.josm.data.cache.JCSCachedTileLoaderJob.run(JCSCachedTileLoaderJob.java:236)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 in reply to:  description Changed 6 months ago by Don-vip

Owner: changed from team to anonymous
Status: newneedinfo

Replying to anonyme:

Java version: null, null, null

What is your java runtime?

comment:2 Changed 6 months ago by Don-vip

Component: CoreCore imagery
Milestone: 18.05

comment:3 Changed 6 months ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 13730/josm:

fix #16277 - catch SecurityException when loading tiles

comment:4 Changed 5 months ago by Don-vip

Ticket #16296 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.