Modify

Opened 6 weeks ago

Closed 6 weeks ago

Last modified 5 weeks ago

#16275 closed defect (invalid)

false positives in validator

Reported by: RailAir Owned by: team
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report Cc: marxin

Description

What steps will reproduce the problem?

  1. apply validator in the area http://tools.geofabrik.de/osmi/?view=areas&lon=12.49548&lat=50.78867&zoom=14&opacity=0.64
  2. creates 674 warnings, most of them buildings with almost rectangular angle (356!)
  1. very slow (more then 3 min.) "start the wrong ordered lines". There are some open MPs. See attached screenshot. Version JOSM 13576 lasts only about 1 min.
  1. The crossing building with the border of landuse=residential isn't a failure in Germany in all cases. A builing can be situated in different landuses.
  1. The also #16264

What is the expected result?

Buildings are not always rectangular. In the mentioned area are a lot of buildings connected and it's nearly impossible to fix it, if they arn't rectangular. My hint: don't check the rectangularity. That could cause more confidence in the validator results.

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-09 21:51:30 +0200 (Wed, 09 May 2018)
Revision:13722
Build-Date:2018-05-10 01:33:33
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13722 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1709 (16299)
Memory Usage: 405 MB / 2048 MB (121 MB allocated, but free)
Java version: 10.0.1+10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024, \Display1 1280x1024
Maximum Screen Size: 1280x1024
VM arguments: [--add-modules=ALL-DEFAULT,javafx.deploy, -Djava.security.manager, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm-latest.jnlp, --add-modules=java.activation,java.se.ee, --add-exports=java.base/sun.security.util=ALL-UNNAMED, --add-exports=java.base/sun.security.x509=ALL-UNNAMED, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-exports=javafx.graphics/com.sun.javafx.application=ALL-UNNAMED, --add-exports=jdk.deploy/com.sun.deploy.config=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.home=<java.home>, -Djnlpx.remove=false, -Djnlpx.offline=false, -Djnlpx.relaunch=true, -Djnlpx.session.data=%UserProfile%\AppData\Local\Temp\session17689901029967130306, -Djnlpx.heapsize=NULL,NULL, -Djava.security.policy=file:<java.home>\conf\security\javaws.policy, -DtrustProxy=true, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\31\583aa85f-47748eac, --illegal-access=deny, --add-modules=ALL-DEFAULT, --add-exports=java.base/com.sun.net.ssl.internal.ssl=jdk.deploy, --add-exports=java.base/jdk.internal.misc=jdk.deploy, --add-exports=java.base/jdk.internal.util.jar=jdk.deploy, --add-exports=java.base/sun.net.www=jdk.deploy, --add-exports=java.base/sun.net.www.protocol.file=jdk.deploy, --add-exports=java.base/sun.net.www.protocol.http=jdk.deploy, --add-exports=java.base/sun.net.www.protocol.http.ntlm=jdk.deploy, --add-exports=java.base/sun.net.www.protocol.https=jdk.deploy, --add-exports=java.base/sun.net.www.protocol.jar=jdk.deploy, --add-exports=java.base/sun.nio=jdk.deploy, --add-exports=java.base/sun.reflect.misc=jdk.deploy, --add-exports=java.base/sun.security.action=jdk.deploy, --add-exports=java.base/sun.security.pkcs=jdk.deploy, --add-exports=java.base/sun.security.provider=jdk.deploy, --add-exports=java.base/sun.security.provider.certpath=jdk.deploy, --add-exports=java.base/sun.security.rsa=jdk.deploy, --add-exports=java.base/sun.security.ssl=jdk.deploy, --add-exports=java.base/sun.security.timestamp=jdk.deploy, --add-exports=java.base/sun.security.util=jdk.deploy, --add-exports=java.base/sun.security.validator=jdk.deploy, --add-exports=java.base/sun.security.x509=jdk.deploy, --add-exports=java.base/sun.usagetracker=jdk.deploy, --add-exports=java.desktop/sun.awt=jdk.deploy, --add-exports=java.naming/com.sun.jndi.toolkit.url=jdk.deploy, --add-exports=java.base/jdk.internal.misc=jdk.javaws, --add-exports=java.desktop/com.sun.media.sound=jdk.javaws, --add-exports=java.desktop/sun.awt=jdk.javaws, --add-exports=java.desktop/sun.awt.image=jdk.javaws, --add-exports=java.base/jdk.internal.misc=jdk.plugin, --add-exports=java.base/sun.net=jdk.plugin, --add-exports=java.base/sun.net.www=jdk.plugin, --add-exports=java.base/sun.net.www.protocol.jar=jdk.plugin, --add-exports=java.base/sun.security.action=jdk.plugin, --add-exports=java.base/sun.security.util=jdk.plugin, --add-exports=java.desktop/com.sun.media.sound=jdk.plugin, --add-exports=java.desktop/java.awt.peer=jdk.plugin, --add-exports=java.desktop/sun.applet=jdk.plugin, --add-exports=java.desktop/sun.applet.resources=jdk.plugin, --add-exports=java.desktop/sun.awt=jdk.plugin, --add-exports=java.desktop/sun.awt.windows=jdk.plugin, --add-exports=java.desktop/sun.swing=jdk.plugin, --add-exports=jdk.jsobject/jdk.internal.netscape.javascript.spi=jdk.plugin, --add-exports=java.desktop/sun.awt.image=jdk.plugin, -Djdk.module.main=jdk.plugin]
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (34109)
+ editgpx (34109)
+ jogl (1.1.0)
+ kendzi3d-resources (0.0.1)
+ log4j (34038)
+ mbtiles (a3e491d)
+ osmarender (34096)
+ pbf (34109)
+ poly (34098)
+ undelete (34109)

Tagging presets:
+ C:\Program Files (x86)\JOSM\Presets_Historic_Stone.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'presets/memorial.png'
- W: [NODE, CLOSEDWAY] Historic Memorial: Could not get presets icon presets/memorial.png
- E: Fehler beim Laden des Bildes 'presets/wayside_shrine.png'
- W: [NODE] Historic Wayside Shrine: Could not get presets icon presets/wayside_shrine.png
- E: Fehler beim Laden des Bildes 'presets/wayside_cross.png'
- W: [NODE] Historic Wayside Cross: Could not get presets icon presets/wayside_cross.png
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (1)

validator_message.png (5.6 KB) - added by RailAir 6 weeks ago.

Download all attachments as: .zip

Change History (4)

Changed 6 weeks ago by RailAir

Attachment: validator_message.png added

comment:1 in reply to:  description Changed 6 weeks ago by Don-vip

Resolution: invalid
Status: newclosed

Replying to RailAir:

  1. creates 674 warnings, most of them buildings with almost rectangular angle (356!)

The test works as intended. You can disable it if you don't like it.

  1. very slow (more then 3 min.) "start the wrong ordered lines". There are some open MPs. See attached screenshot. Version JOSM 13576 lasts only about 1 min.

I couldn't reproduce and this test wasn't modified.

  1. The crossing building with the border of landuse=residential isn't a failure in Germany in all cases. A builing can be situated in different landuses.

I looked at some errors on your area and confirm the test is correct. It doesn't make sense for a landuse to cross a building. They should be on a side of it.

  1. The also #16264

I already have fixed this issue.

Buildings are not always rectangular.

I know, the test does not check that.

In the mentioned area are a lot of buildings connected and it's nearly impossible to fix it, if they arn't rectangular.

Of course it is possible. Try the autofix and you will see only one node moves to make sure the "almost" right angle becomes an exact right angle (90°). The values can be tuned (see #16189) but the test is useful and working.

Last edited 6 weeks ago by Don-vip (previous) (diff)

comment:2 Changed 5 weeks ago by Klumbumbus

Cc: marxin added

comment:3 Changed 5 weeks ago by Don-vip

OK the test is not working so great, I have downgraded it to information level in #16280

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.