Modify

Opened 7 months ago

Closed 7 months ago

#16264 closed defect (fixed)

Validator creates wrong messages JOSM 13710

Reported by: RailAir Owned by: team
Priority: normal Milestone: 18.05
Component: Core validator Version:
Keywords: template_report landuse railway waterway Cc: marxin, Klumbumbus

Description

What steps will reproduce the problem?

  1. open http://tools.geofabrik.de/osmi/?view=areas&lon=12.49548&lat=50.78867&zoom=14&opacity=0.64 in JOSM 13710 and press Validation (in German Pruefung")
  2. In the above mentioned area it creates more then 400 messages. In JOSM 13576 only about 60.
  3. One of the wrong messages is the crossing of landuse with railway or waterway

What is the expected result?

no wrong messages like mentioned above

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

I switched back to JOSM 13576.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-26 22:16:39 +0200 (Mon, 26 Mar 2018)
Revision:13576
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Build-Date:2018-03-26 20:45:23
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13576 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1709 (16299)
Memory Usage: 292 MB / 2048 MB (56 MB allocated, but free)
Java version: 10.0.1+10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024, \Display1 1280x1024
Maximum Screen Size: 1280x1024
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (34109)
+ editgpx (34109)
+ jogl (1.1.0)
+ kendzi3d-resources (0.0.1)
+ log4j (34038)
+ mbtiles (a3e491d)
+ osmarender (34096)
+ pbf (34109)
+ poly (34098)
+ undelete (34109)

Tagging presets:
+ C:\Program Files (x86)\JOSM\Presets_Historic_Stone.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'presets/memorial.png'
- W: [NODE, CLOSEDWAY] Historic Memorial: Could not get presets icon presets/memorial.png
- E: Fehler beim Laden des Bildes 'presets/wayside_shrine.png'
- W: [NODE] Historic Wayside Shrine: Could not get presets icon presets/wayside_shrine.png
- E: Fehler beim Laden des Bildes 'presets/wayside_cross.png'
- W: [NODE] Historic Wayside Cross: Could not get presets icon presets/wayside_cross.png
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (6)

comment:1 Changed 7 months ago by Don-vip

Component: CoreCore validator

comment:2 Changed 7 months ago by Don-vip

Keywords: landuse railway waterway added

comment:3 Changed 7 months ago by Don-vip

Cc: marxin Klumbumbus added
Milestone: 18.05

comment:4 Changed 7 months ago by Don-vip

Caused by #16188

comment:5 Changed 7 months ago by Don-vip

And #16189 for the high number of warnings.

comment:6 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13721/josm:

fix #16264, see #16188, see #16189 - reduce validator false positives:

  • increase tolerance of buildings with almost right angle to 1 degree
  • detect crossing residential areas only with themselves and buildings
  • fix crossing railways messages

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.