Modify

#16178 closed defect (duplicate)

OAuth login does not work when trying to upload changeset

Reported by: floscher Owned by: team
Priority: minor Milestone:
Component: Core Version: tested
Keywords: oauth Cc:

Description

I tried to upload a changeset with a JOSM instance, in which I wasn't already logged in.

When JOSM tried to upload I was prompted to authenticate. I chose OAuth authentication in semi-automatic mode.

I then clicked "Retrieve Request Token". A dialog with a indeterminate progress bar appears and disappears, but no browser window opens.

Expected behaviour:
A browser window opens with the URL https://www.openstreetmap.org/oauth/authorize?oauth_token=some_oauth_token

When I go into Preferences › Connection settings › Authentication › Authorize now everything works as expected. Only when triggered by an upload I can reproduce the faulty behaviour. Also the fully automatic authentication works in both cases.

Attachments (0)

Change History (2)

comment:1 Changed 10 months ago by floscher

The request token is retrieved successfully:
2018-04-17 12:34:56.789 INFORMATION: GET https://www.openstreetmap.org/oauth/request_token -> 200 (124 B)
But neither the UI is updated, nor is an exception thrown.

comment:2 Changed 10 months ago by floscher

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14091.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.