Modify

#16150 closed defect (duplicate)

DividedScale$RangeViolatedError: the new range must be within a single subrange (2)

Reported by: mpasha Owned by: team
Priority: normal Milestone:
Component: Core mappaint Version: latest
Keywords: template_report mapcss range Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-31 19:41:26 +0200 (Sat, 31 Mar 2018)
Build-Date:2018-04-01 01:32:37
Revision:13591
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13591 ru) Windows 10 64-Bit
OS Build number: Windows 10 Enterprise 2016 LTSB 1607 (14393)
Memory Usage: 254 MB / 989 MB (41 MB allocated, but free)
Java version: 1.8.0_131-b11, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
VM arguments: [-Djosm.home=<josm.pref>]
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (23)
+ CADTools
+ DirectDownload (34109)
+ DirectUpload (34109)
+ EasyPresets (1515942663)
+ FastDraw (34109)
+ FixAddresses (34109)
+ HouseNumberTaggingTool (34109)
+ ImproveWay (17)
+ InfoMode (34038)
+ Mapillary (v1.5.10)
+ OpeningHoursEditor (34095)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34109)
+ continuosDownload (68)
+ contourmerge (1032)
+ download_along (34081)
+ editgpx (34109)
+ ejml (34126)
+ ext_tools (34109)
+ geotools (34125)
+ gpsblam (34095)
+ graphview (34109)
+ gson (34038)
+ imagery_offset_db (34109)
+ jogl (1.1.0)
+ jts (34038)
+ log4j (34038)
+ mapdust (34095)
+ markseen (7)
+ merge-overlap (34109)
+ namemanager (34109)
+ osm-obj-info (1509723997)
+ photoadjust (34109)
+ print (34109)
+ reltoolbox (34130)
+ tag2link (34109)
+ tageditor (34109)
+ tagging-preset-tester (34109)
+ terracer (34109)
+ todo (30303)
+ utilsplugin2 (34109)

Tagging presets:
+ https://raw.githubusercontent.com/ruosm-presets/literan-moscow/master/russian_shops.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/UA.zip
+ https://pasharm.github.io/POI_Ukraine/POI_Ukraine.xml

Map paint styles:
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
+ https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss
- D:\GitHub\Objects_on_the_map\Objects_on_the_map.mapcss
- D:\Programs\JOSM_Portable\Map Styles\Test\potlatch2.mapcss
- D:\Programs\JOSM_Portable\Map Styles\elemstyles1.mapcss
+ D:\WebStormProjects\Ones test style JOSM\Ones test.mapcss
- D:\Programs\JOSM_Portable\Map Styles\New basic style 1.9_2017-11-07.mapcss
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- D:\Programs\JOSM_Portable\Map Styles\Test\osm-results\mapnik.mapcss

Validator rules:
- <josm.pref>\validator\indoorhelper.validator.mapcss

Last errors/warnings:
- W: Unable to convert property fill-color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found  of type class java.lang.String!
- W: Unable to convert property fill-color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property fill-color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found  of type class java.lang.String!
- W: Unable to convert property fill-color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property fill-color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found  of type class java.lang.String!
- W: Unable to convert property fill-color to type class java.awt.Color: found # of type class java.lang.String!
- E: Handled by bug report queue: java.lang.AssertionError. Причина: java.lang.AssertionError: Range violated: the new range must be within a single subrange (2) (object: отношение 1749468, current style: StyleCache{PLAIN: DS{[0.0, 238.8657133911758, 955.4628535647032, Infinity] [null, [LineElemStyle{z_idx=[3.0/5.0/0.0] width=1.0 realWidth=0.0 color=#808080 dashed=null dashedColor=null linejoin=round linecap=round}], null]} SELECTED: null}, scale: 171.75593729366878, new stylelist: [AreaElemStyle{z_idx=[1.0/0.0/0.0] color=#cb9999(alpha=50) fillImage=[null] extent=[null] extentThreshold=[null]}, TextElement{z_idx=[4.9/0.0/0.0] text=TextLabel{labelCompositionStrategy={DeriveLabelFromNameTagsCompositionStrategy} font=java.awt.Font[family=Droid Sans,name=Droid Sans,style=plain,size=8] color=#ffffff} labelPositionStrategy=CompletelyInsideAreaStrategy [offsetX=0.0, offsetY=0.0]}], new range: |s29.858214173896975-Infinity). Причина: org.openstreetmap.josm.gui.mappaint.DividedScale$RangeViolatedError: the new range must be within a single subrange (2)


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.AssertionError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
	at java.util.concurrent.ForkJoinTask.getThrowableException(ForkJoinTask.java:598)
	at java.util.concurrent.ForkJoinTask.reportException(ForkJoinTask.java:677)
	at java.util.concurrent.ForkJoinTask.join(ForkJoinTask.java:720)
	at java.util.concurrent.ForkJoinPool.invoke(ForkJoinPool.java:2616)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.paintWithLock(StyledMapRenderer.java:1602)
	at org.openstreetmap.josm.data.osm.visitor.paint.StyledMapRenderer.render(StyledMapRenderer.java:1574)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:494)
	at org.openstreetmap.josm.gui.layer.AbstractMapViewPaintable$CompatibilityModeLayerPainter.paint(AbstractMapViewPaintable.java:27)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:470)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:585)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:492)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1579)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1502)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.AssertionError: Range violated: the new range must be within a single subrange (2) (object: отношение 1749468, current style: StyleCache{PLAIN: DS{[0.0, 238.8657133911758, 955.4628535647032, Infinity] [null, [LineElemStyle{z_idx=[3.0/5.0/0.0] width=1.0 realWidth=0.0 color=#808080 dashed=null dashedColor=null linejoin=round linecap=round}], null]} SELECTED: null}, scale: 171.75593729366878, new stylelist: [AreaElemStyle{z_idx=[1.0/0.0/0.0] color=#cb9999(alpha=50) fillImage=[null] extent=[null] extentThreshold=[null]}, TextElement{z_idx=[4.9/0.0/0.0] text=TextLabel{labelCompositionStrategy={DeriveLabelFromNameTagsCompositionStrategy} font=java.awt.Font[family=Droid Sans,name=Droid Sans,style=plain,size=8] color=#ffffff} labelPositionStrategy=CompletelyInsideAreaStrategy [offsetX=0.0, offsetY=0.0]}], new range: |s29.858214173896975-Infinity)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:198)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.get(ElemStyles.java:131)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.add(ComputeStyleListWorker.java:178)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.visit(ComputeStyleListWorker.java:143)
	at org.openstreetmap.josm.data.osm.Relation.accept(Relation.java:185)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.acceptDrawable(ComputeStyleListWorker.java:124)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.computeDirectly(ComputeStyleListWorker.java:111)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.compute(ComputeStyleListWorker.java:88)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.compute(ComputeStyleListWorker.java:34)
	at java.util.concurrent.RecursiveTask.exec(RecursiveTask.java:94)
	at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
	at java.util.concurrent.ForkJoinPool$WorkQueue.tryRemoveAndExec(ForkJoinPool.java:1107)
	at java.util.concurrent.ForkJoinPool.awaitJoin(ForkJoinPool.java:2046)
	at java.util.concurrent.ForkJoinTask.doJoin(ForkJoinTask.java:390)
	at java.util.concurrent.ForkJoinTask.join(ForkJoinTask.java:719)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.compute(ComputeStyleListWorker.java:97)
	at org.openstreetmap.josm.data.osm.visitor.paint.ComputeStyleListWorker.compute(ComputeStyleListWorker.java:34)
	at java.util.concurrent.RecursiveTask.exec(RecursiveTask.java:94)
	at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
	at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)
	at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)
	at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)
Caused by: org.openstreetmap.josm.gui.mappaint.DividedScale$RangeViolatedError: the new range must be within a single subrange (2)
	at org.openstreetmap.josm.gui.mappaint.DividedScale.putImpl(DividedScale.java:147)
	at org.openstreetmap.josm.gui.mappaint.DividedScale.put(DividedScale.java:102)
	at org.openstreetmap.josm.gui.mappaint.StyleCache.put(StyleCache.java:50)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:195)
	... 21 more

Attachments (0)

Change History (3)

comment:1 Changed 11 months ago by Don-vip

Component: CoreCore mappaint
Summary: ErrorDividedScale$RangeViolatedError: the new range must be within a single subrange (2)

comment:2 Changed 11 months ago by Don-vip

Keywords: mapcss range added

comment:3 Changed 11 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #16120.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.