Modify

Opened 7 months ago

Closed 7 months ago

#16151 closed defect (duplicate)

Layer offset still active after clicking OK

Reported by: r00tcz Owned by: team
Priority: major Milestone:
Component: Core imagery Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Add Bing layer
  2. Right click layer and select "New offset"
  3. Move Bing layer
  4. Click OK to accept new offset

What is the expected result?

Offset will be accepted and moving of Bing layer by left mouse button will stop. User will be able to edit OSM data as expected..

What happens instead?

Offset dialog disappers, but layer move mode is still active. OSM layers can't be edited as left mouse button continues to move the Bing layer. Trying to select layer move again doesn't work. Deleting Bing layer doesn't solve this problem either. Even after deleting it, OSM data still can't be edited. All layers have to be deleted/removed for this bug to stop.

Please provide any additional information below. Attach a screenshot if possible.

Last version that DOES NOT have this bug is 13533. Stable 13576 is buggy as well.
Please fix this, it's impossible to use JOSM like this!

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-03-31 19:41:26 +0200 (Sat, 31 Mar 2018)
Build-Date:2018-04-01 01:32:37
Revision:13591
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13591 en) Windows XP 32-Bit
OS Build number: Microsoft Windows XP (1.511.1 () (Obsolete data - do not use))
Memory Usage: 298 MB / 989 MB (102 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1600x1200, \Display1 1600x1200
Maximum Screen Size: 1600x1200
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (1511895663)
+ DirectDownload (34109)
+ DirectUpload (34109)
+ PicLayer (34109)
+ apache-commons (34109)
+ colorscheme (34109)
+ continuosDownload (68)
+ download_along (34081)
+ editgpx (34109)
+ ejml (34126)
+ geotools (34125)
+ jts (34038)
+ opendata (34132)
+ pbf (34109)
+ reltoolbox (34130)
+ reverter (34109)
+ utilsplugin2 (34109)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&zip=1
+ C:\Program Files\JOSM\Styles_Power-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/OsmcSKCZPL&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- C:\Program Files\JOSM\Power-ref.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (0)

Change History (1)

comment:1 Changed 7 months ago by Klumbumbus

Component: CoreCore imagery
Resolution: duplicate
Status: newclosed

Closed as duplicate of #16133.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.