Modify

Opened 4 years ago

Closed 10 months ago

#15397 closed enhancement (fixed)

Make toolbar buttons of JCheckBoxMenuItems reflect toggle state

Reported by: ris Owned by: simon04
Priority: normal Milestone: 21.03
Component: Core Version:
Keywords: toggle menu toolbar button Cc: iav

Description

Simple one. Toolbar buttons created from menu items that are JCheckBoxMenuItems don't reflect the toggle state of that option. It shouldn't be too tricky to detect this case and create a JToggleButton that's hooked up to the same ButtonModel.

I hope to get round to picking this up myself at some point, but putting it here in case anyone beats me to it.

Attachments (0)

Change History (5)

comment:1 Changed 10 months ago by skyper

Keywords: button added

comment:2 Changed 10 months ago by skyper

Ticket #8705 has been marked as a duplicate of this ticket.

comment:3 Changed 10 months ago by skyper

Cc: iav added

comment:4 Changed 10 months ago by simon04

Milestone: 21.03
Owner: changed from team to simon04
Status: newassigned

comment:5 Changed 10 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 17667/josm:

fix #15397 - Toolbar: make ToggleAction buttons reflect toggle state

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.