Modify

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#15372 closed defect (fixed)

AssertionError at startup : verifying plugins required conditions

Reported by: ocivelo@… Owned by: ocivelo@…
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. startup of josm

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 fr) Linux Bodhi 2.3.0
Memory Usage: 115 MB / 243 MB (57 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800

Plugins:
+ cadastre-fr
+ ejml
+ geotools
+ jts
+ measurement

Last errors/warnings:
- E: Handled by bug report queue: java.lang.AssertionError: unable to find dependency apache-commons for plugin cadastre-fr


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.AssertionError: unable to find dependency apache-commons for plugin cadastre-fr
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:856)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:903)
	at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:974)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:850)

Attachments (1)

shot-2017-09-30_06-53-13.jpg (287.2 KB) - added by ocivelo@… 18 months ago.

Download all attachments as: .zip

Change History (6)

Changed 18 months ago by ocivelo@…

comment:1 Changed 18 months ago by ocivelo@…

Owner: changed from team to ocivelo@…
Status: newneedinfo

ultimate version 12908 doesnot crash , i will trie to use it

comment:2 Changed 18 months ago by Don-vip

Summary: error at startup : vérifying greffons required conditionsAssertionError at startup : verifying plugins required conditions

comment:3 Changed 18 months ago by Don-vip

Milestone: 17.09

comment:4 Changed 18 months ago by Don-vip

Resolution: fixed
Status: needinfoclosed

In 12910/josm:

fix #15372 - simply log an error if a dependency cannot be found. Real error will occur later and be managed better

comment:5 Changed 18 months ago by Don-vip

Ticket #15383 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain ocivelo@….
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.