Modify

Opened 7 years ago

Closed 7 years ago

#15373 closed defect (duplicate)

DataIntegrityProblemException: Deleted member referenced in trying to revert a changset

Reported by: georges.dutreix@… Owned by: Upliner
Priority: major Milestone:
Component: Plugin reverter Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Try to revert the changset 52489487

What is the expected result?

I have done a big mistake, changset 52489487 (I am the author) with a lot of ways and nodes duplicated. I am trying to revert with the reverter plugin.

What happens instead?

I get an error message.

Please provide any additional information below. Attach a screenshot if possible.

The mistake was done while duplicating a relation. Nodes and ways have been duplicated two kilometers in the south (??). And I didn't notice that before saving :-(

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-08 23:34:46 +0200 (Fri, 08 Sep 2017)
Build-Date:2017-09-09 01:31:50
Revision:12794
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12794 fr) Linux Ubuntu 16.04.3 LTS
Memory Usage: 609 MB / 876 MB (77 MB allocated, but free)
Java version: 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x1200
Maximum Screen Size: 1600x1200
Java package: openjdk-8-jre:amd64-8u131-b11-2ubuntu1.16.04.3

Dataset consistency test:
[DELETED REFERENCED] {Relation id=7573289 version=2 VT [relation 7573288, relation 7573287]} refers to deleted primitive {Relation id=7573288 version=11 D]}


Plugins:
+ cadastre-fr (33514)
+ ejml (32680)
+ geotools (33380)
+ jts (32699)
+ reverter (33572)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1

Last errors/warnings:
- W: Conflit dans les données - <html>Cette relation a été modifiée à l’extérieur de l’éditeur.<br><br>Vous ne pouvez pas appliquer ni continuer les modifications.<br><br>Voulez-vous créer un conflit et fermer l’éditeur ?</html>
- W: Modifications non enregistrées - <html>La relation a été modifiée.<br><br>Voulez-vous enregistrer vos modifications ?</html>
- W: JOSM devrait trouver lʼobjet [chemin -48181] dans le jeu de données, mais il nʼest pas là. Merci de le signaler à https://josm.openstreetmap.de. Ce nʼest pas une erreur critique, il ne devrait pas y avoir de problème pour continuer votre travail.
- E: java.lang.Exception
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>
- E: Requête incorrecte - <html>Le serveur 'api.openstreetmap.org' a signalé une requête erronée.<br><br>La zone que vous voulez télécharger est trop grande ou votre requête est trop grosse. <br>Veuillez sélectionner une zone plus petite ou utiliser un fichier d’export fourni par la communauté OSM.</html>
- W: Avertissement - <html>Les données ont des conflits non résolus dans le calque 'Calque de données 2'.<br>Vous devez d’abord les résoudre avant d’envoyer.</html>
- E: Impossible d’ouvrir la page. - Impossible d’ouvrir la page d’aide. L’adresse web est vide.
- W: Invalid jar file ''<josm.pref>/plugins/reverter.jar.new'' (exists: false, canRead: false)
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=7573289 version=2 VT [relation 7573288, relation 7573287]}


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted member referenced: {Relation id=7573289 version=2 VT [relation 7573288, relation 7573287]}
	at org.openstreetmap.josm.data.osm.Relation.checkMembers(Relation.java:503)
	at org.openstreetmap.josm.data.osm.Relation.fireMembersChanged(Relation.java:515)
	at org.openstreetmap.josm.data.osm.Relation.setMembers(Relation.java:65)
	at org.openstreetmap.josm.data.osm.Relation.cloneFrom(Relation.java:249)
	at org.openstreetmap.josm.command.ChangeCommand.executeCommand(ChangeCommand.java:81)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:80)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:71)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:99)
	at reverter.RevertChangesetTask$3.run(RevertChangesetTask.java:126)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:109)
	at java.awt.WaitDispatchSupport$2.run(WaitDispatchSupport.java:184)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:229)
	at java.awt.WaitDispatchSupport$4.run(WaitDispatchSupport.java:227)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(WaitDispatchSupport.java:227)
	at java.awt.Dialog.show(Dialog.java:1084)
	at java.awt.Component.show(Component.java:1671)
	at java.awt.Component.setVisible(Component.java:1623)
	at java.awt.Window.setVisible(Window.java:1014)
	at java.awt.Dialog.setVisible(Dialog.java:1005)
	at org.openstreetmap.josm.gui.progress.swing.PleaseWaitProgressMonitor.lambda$doBeginTask$3(PleaseWaitProgressMonitor.java:256)
	at org.openstreetmap.josm.gui.progress.swing.PleaseWaitProgressMonitor.lambda$doInEDT$0(PleaseWaitProgressMonitor.java:114)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 by Don-vip, 7 years ago

Component: CorePlugin reverter
Owner: changed from team to Upliner
Summary: error in trying to revert a changsetDataIntegrityProblemException: Deleted member referenced in trying to revert a changset

comment:2 by Don-vip, 7 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15316.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.