Modify

Opened 4 years ago

Closed 4 years ago

#15351 closed defect (duplicate)

JOSM crashed while regarding history of a way-element (Strg-H shortcut)

Reported by: ralf@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Clicking a closed way-element (in my case a natural=landform object)
  2. Strg+H to view obejcts history
  3. Change displayed item to compare edit steps of different users

What is the expected result?

Displaying canges

What happens instead?

Error screen appeared

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 de) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 389 MB / 989 MB (123 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.7)
+ RoadSigns (33579)
+ alignways (33182)
+ apache-commons (33517)
+ apache-http (32699)
+ areaselector (1504038934)
+ austriaaddresshelper (1495805712)
+ buildings_tools (33004)
+ continuosDownload (53)
+ imagery_offset_db (33547)
+ log4j (32699)
+ osmarender (33004)
+ public_transport (33166)
+ routes (33532)
+ tageditor (33579)
+ turnlanes-tagging (254)
+ turnrestrictions (33537)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/DestinationSignRelation&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: -1
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: -1


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-5-thread-1 (807)
java.lang.ArrayIndexOutOfBoundsException: -1
	at java.util.ArrayList.fastRemove(Unknown Source)
	at java.util.ArrayList.remove(Unknown Source)
	at org.openstreetmap.josm.gui.MapStatus.setHelpText(MapStatus.java:1015)
	at org.openstreetmap.josm.gui.MapStatus.setHelpText(MapStatus.java:1004)
	at org.openstreetmap.josm.plugins.mapillary.utils.MapillaryUtils.updateHelpText(MapillaryUtils.java:286)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySquareDownloadRunnable.run(MapillarySquareDownloadRunnable.java:29)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by bastiK

Component: CorePlugin mapillary
Owner: changed from team to floscher

comment:2 Changed 4 years ago by Don-vip

Component: Plugin mapillaryCore
Owner: changed from floscher to team
Resolution: duplicate
Status: newclosed

Closed as duplicate of #15249.
Closed as duplicate of #15249.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.