Modify

Opened 19 months ago

Closed 18 months ago

Last modified 18 months ago

#15249 closed defect (fixed)

AIOOBE at MapStatus.setHelpText

Reported by: anonymous Owned by: team
Priority: normal Milestone: 17.09
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-09-02 14:47:18 +0200 (Sat, 02 Sep 2017)
Build-Date:2017-09-02 20:53:16
Revision:12712
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12712 nl) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1703 (15063)
Memory Usage: 424 MB / 989 MB (88 MB allocated, but free)
Java version: 1.8.0_144-b01, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.7)
+ apache-commons (33517)
+ apache-http (32699)
+ ejml (32680)
+ geojson (55)
+ geotools (33380)
+ jts (32699)
+ opendataservices (0.6.10)
+ reverter (33572)
+ tageditor (33579)
+ turnlanes (33294)
+ turnrestrictions (33537)
+ utilsplugin2 (33579)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BENELUX&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/NL.zip
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/DE.zip
+ https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/NumberedCycleNodeNetworks&zip=1
+ https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
+ %UserProfile%\Downloads\Bag-plugin-0.6.8\Ods-bag-style-0.6.8.mapcss

Last errors/warnings:
- W: Initializing map style https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs.zip completed in 31 ms (1 errors, 0 warnings)
- W: Laden van Kaarttekenstijlen vanaf '%UserProfile%\Downloads\Bag-plugin-0.6.8\Ods-bag-style-0.6.8.mapcss' mislukt. Exceptie was: java.io.FileNotFoundException: %UserProfile%\Downloads\Bag-plugin-0.6.8\Ods-bag-style-0.6.8.mapcss (Het systeem kan het opgegeven pad niet vinden)
- E: java.io.FileNotFoundException: %UserProfile%\Downloads\Bag-plugin-0.6.8\Ods-bag-style-0.6.8.mapcss (Het systeem kan het opgegeven pad niet vinden)
- E: java.nio.file.NoSuchFileException: %UserProfile%\Downloads\Bag-plugin-0.6.8
- W: Initializing map style %UserProfile%\Downloads\Bag-plugin-0.6.8\Ods-bag-style-0.6.8.mapcss completed in 0 ms (1 errors, 0 warnings)
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Geen standaarlaag geselecteerd, kies eerst de laag.
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: -1
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: -1


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-3-thread-2 (361)
java.lang.ArrayIndexOutOfBoundsException: -1
	at java.util.ArrayList.fastRemove(Unknown Source)
	at java.util.ArrayList.remove(Unknown Source)
	at org.openstreetmap.josm.gui.MapStatus.setHelpText(MapStatus.java:1015)
	at org.openstreetmap.josm.gui.MapStatus.setHelpText(MapStatus.java:1004)
	at org.openstreetmap.josm.plugins.mapillary.utils.MapillaryUtils.updateHelpText(MapillaryUtils.java:286)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySquareDownloadRunnable.run(MapillarySquareDownloadRunnable.java:29)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 19 months ago by Don-vip

Component: CorePlugin mapillary
Owner: changed from team to floscher

comment:2 Changed 18 months ago by Don-vip

Component: Plugin mapillaryCore
Milestone: 17.09
Owner: changed from floscher to team
Summary: System CrashAIOOBE at MapStatus.setHelpText

comment:3 Changed 18 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12863/josm:

fix #15249 - synchronize accesses to MapStatus help text

comment:4 Changed 18 months ago by Don-vip

Ticket #15351 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.