Modify

Opened 6 years ago

Closed 6 years ago

#14712 closed defect (duplicate)

Bug report by creating node from + on way

Reported by: SHARCRASH Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. created a closed way
  2. wanted to create a new node via the + on the way

What is the expected result?

New dragged node.

What happens instead?

Nothing visible, just the error report window came up.

Please provide any additional information below. Attach a screenshot if possible.

Printscreen

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-04-02 01:45:00 +0200 (Sun, 02 Apr 2017)
Build-Date:2017-04-02 01:34:50
Revision:11826
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11826 en) Windows 7 64-Bit
Memory Usage: 490 MB / 989 MB (136 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1280x1024, \Display1 1280x1024
Maximum Screen Size: 1280x1024
Dataset consistency test: No problems found

Plugins:
+ SimplifyArea (33004)
+ buildings_tools (33004)
+ continuosDownload (53)
+ contourmerge (1030)
+ reltoolbox (33265)
+ reverter (33088)
+ turnrestrictions (33088)
+ undelete (33263)
+ utilsplugin2 (33212)
+ wikipedia (33098)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
+ https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Enhanced_Lane_and_Road_Attributes&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: Handled by bug report queue: java.lang.NullPointerException: start
- E: Handled by bug report queue: java.lang.NullPointerException: start


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException: start
	at java.util.Objects.requireNonNull(Unknown Source)
	at org.openstreetmap.josm.command.MoveCommand.<init>(MoveCommand.java:125)
	at org.openstreetmap.josm.actions.mapmode.SelectAction$VirtualManager.createMiddleNodeFromVirtual(SelectAction.java:1232)
	at org.openstreetmap.josm.actions.mapmode.SelectAction$VirtualManager.access$800(SelectAction.java:1155)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseDragged(SelectAction.java:551)
	at java.awt.AWTEventMulticaster.mouseDragged(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

Untitled-1.jpg (301.6 KB) - added by SHARCRASH 6 years ago.
Printscreen

Download all attachments as: .zip

Change History (3)

Changed 6 years ago by SHARCRASH

Attachment: Untitled-1.jpg added

Printscreen

comment:1 Changed 6 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13724.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.