Modify

Opened 3 years ago

Closed 7 months ago

#13724 closed defect (fixed)

NPE in MoveCommand.<init> via SelectAction.mouseDragged

Reported by: anonymous Owned by: team
Priority: normal Milestone: 18.10
Component: Core Version:
Keywords: template_report Cc: SHARCRASH

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en) Windows 7 64-Bit
Memory Usage: 177 MB / 247 MB (90 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (32796)

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.command.MoveCommand.<init>(MoveCommand.java:119)
	at org.openstreetmap.josm.actions.mapmode.SelectAction$VirtualManager.createMiddleNodeFromVirtual(SelectAction.java:1235)
	at org.openstreetmap.josm.actions.mapmode.SelectAction$VirtualManager.access$800(SelectAction.java:1158)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseDragged(SelectAction.java:554)
	at java.awt.AWTEventMulticaster.mouseDragged(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseDragged(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (15)

comment:1 Changed 3 years ago by Don-vip

Milestone: 16.09

comment:2 Changed 3 years ago by simon04

Tickets related to SelectAction and SelectAction$VirtualManager in the stack trace: #13537, #13677, #13724.

comment:3 Changed 3 years ago by simon04

In 11070/josm:

see #13724 - refactor constructors and add parameters validation to detect root cause

comment:4 Changed 3 years ago by simon04

Milestone: 16.0916.10

Milestone renamed

comment:5 Changed 3 years ago by simon04

Cc: michael2404 added

Michael, is this related to #13665 (since #13537/#13677 also involve SelectAction/SelectAction$VirtualManager)?

comment:6 Changed 3 years ago by simon04

Summary: JOSM suddenly stopped immediately after opening and asked me to send a Bug Report.NPE in MoveCommand.<init> via SelectAction.mouseDragged

comment:7 Changed 3 years ago by michael2402

In 11140/josm:

See #13724: Add validation to AddCommand, too.

comment:8 Changed 3 years ago by michael2402

#13665 -> probably no. That issue has to do with rendering a node that is marked as deleted but not incomplete and that is not removed from a way during the data update.

#13729 -> this one looks related, but I don't see how [11079] solved this issue.

comment:9 Changed 3 years ago by michael2402

Milestone: 16.10
Owner: changed from team to anonymous
Status: newneedinfo

I could not find a way to reproduce this. I don't even know if it may happen in the current release of JOSM. We need to wait for someone to trigger this one again and send an error report with the new debugging data.

comment:10 Changed 2 years ago by Don-vip

Ticket #14712 has been marked as a duplicate of this ticket.

comment:11 Changed 2 years ago by Don-vip

Cc: SHARCRASH added; michael2404 removed
Owner: changed from anonymous to team
Status: needinfonew

comment:12 Changed 2 years ago by Don-vip

startEn appears to be null.

comment:13 Changed 22 months ago by Don-vip

Ticket #15087 has been marked as a duplicate of this ticket.

comment:14 Changed 7 months ago by Don-vip

Milestone: 18.10

comment:15 Changed 7 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14343/josm:

fix #13724 - NPE

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.