Modify

Opened 23 months ago

Closed 17 months ago

Last modified 3 months ago

#14645 closed defect (fixed)

Validator: ignoring "Crossing ways" group will actually ignore all"crossing XXX" validators

Reported by: bagage Owned by: team
Priority: normal Milestone: 17.10
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Activate validation for a layer with some Crossing XXX errors
  2. Select "Crossing ways", then "Ignore". Tick "Whole group"
  3. The "Crossing ways" group disappears from the list (but NOT the others ones).
  4. Reclick on "Validation"

What is the expected result?

The list is rebuilt with exactly the same items.

What happens instead?

Actually, all "Crossing XXX" groups will disappear (Crossing barriers, Crossing buildings, Croissing waterway/highway, Crossing waterways, Crossing ways). This is kind of unfortunate since I didn't expected all of them to disappear, but only the Crossing ways group.
Note if that helps: in ~/.local/share/JOSM/validator/ignorederrors, the number "601" is added when ignoring the "Crossing ways" group.

Please provide any additional information below. Attach a screenshot if possible.

Build-Date:2017-04-10 14:26:00
Revision:11883
Is-Local-Build:true

Identification: JOSM/1.5 (11883 SVN en) Linux Debian GNU/Linux 9.0 (stretch)
Memory Usage: 844 MB / 1760 MB (235 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-4-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u121-b13-4
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
Program arguments: [--language=en, ${HOME}/majcadastre/CL337-SAULCE-SUR-RHONE/osm.osm]
Dataset consistency test: No problems found

Plugins:
+ PicLayer (33148)
+ buildings_tools (33004)
+ conflation (0.5.4)
+ jts (32699)
+ rex (26)
+ todo (30000)
+ utilsplugin2 (33212)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@4bc62be5
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@7961f66c
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@1faf13ea
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@492b4e6c
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkSelectedAction@386e41c7

Attachments (0)

Change History (5)

comment:1 Changed 17 months ago by Don-vip

Milestone: 17.10

comment:2 Changed 17 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 12958/josm:

fix #14645 - distinguish crossing ways validator error subtypes to properly ignore the selected group only

comment:3 Changed 3 months ago by bagage

Hey Don-vip. I actually encounted this issue again today. I still think the issue is present because all "Crossing XXX" issues are in 601 validation error, except for some (boundaries, barrier, selfcrossing).

But since JOSM displays lists grouped by title (eg. "Crossing buildings", then "Crossing highways", etc), you may still ignore one group that will disable all of them.

For instance I've disabled "Crossing residential area/way" group because I'm bored of it, ... but it disabled all the others as well which was unexpected! One fix would be to have one custom code per message, or maybe a warning when you want to ignore a group "Warning, it will disable the following groups: <list of groups for the given code>"?

comment:4 in reply to:  3 Changed 3 months ago by Don-vip

Replying to bagage:

Hey Don-vip. I actually encounted this issue again today.

Can you please create a new ticket with full description, status report and a sample file? Thanks.

comment:5 Changed 3 months ago by bagage

Last edited 3 months ago by bagage (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.