Modify

Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#16978 closed defect (fixed)

[Patch] Validation: ignoring "Crossing ways" group will actually ignore all"crossing XXX" groups silently too

Reported by: bagage Owned by: GerdP
Priority: normal Milestone: 18.12
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open the attached file validation.osm and start validation. There should be 3 warnings groups (crossing building/highway, crossing buildings, crossing ways).
  2. Ignore "crossing buildings" group, and select "Whole group"

What is the expected result?

The group is ignored now (OK) and forever.

What happens instead?

The group is properly ignored (removed from the list) for now and forever (will never come back). It remains 2 groups.

BUT if you rerun "Validation"… all warnings are gone! All of them are now ignored.

I would expect either JOSM to be clear that all of these are the same group, or better that only the group I ignored is removed from further validations. Related to https://josm.openstreetmap.de/ticket/14645

Please provide any additional information below. Attach a screenshot if possible.

You can easily reproduce it also by adding value "601" in ignorederrors file.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-10-28 22:27:31 +0100 (Sun, 28 Oct 2018)
Build-Date:2018-10-28 21:33:32
Revision:14382
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14382 fr) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 569 MB / 4436 MB (243 MB allocated, but free)
Java version: 1.8.0_181-8u181-b13-2-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u181-b13-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-21

Plugins:
+ AddrInterpolation (34506)
+ HouseNumberTaggingTool (34517)
+ OpeningHoursEditor (34535)
+ PicLayer (34544)
+ buildings_tools (34572)
+ conflation (0.6.2)
+ jts (34524)
+ poly (34546)
+ scripting (30792)
+ terracer (34584)
+ todo (30306)
+ utilsplugin2 (34506)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (2)

validation.osm (2.5 KB) - added by bagage 5 months ago.
validation.osm with some warnings about crossing ways of multiple categories
16978.patch (11.8 KB) - added by GerdP 5 months ago.

Download all attachments as: .zip

Change History (14)

Changed 5 months ago by bagage

Attachment: validation.osm added

validation.osm with some warnings about crossing ways of multiple categories

comment:1 Changed 5 months ago by GerdP

Owner: changed from team to GerdP

Working on a solution now.

Changed 5 months ago by GerdP

Attachment: 16978.patch added

comment:2 Changed 5 months ago by GerdP

Summary: Validation: ignoring "Crossing ways" group will actually ignore all"crossing XXX" groups silently too[Patch] Validation: ignoring "Crossing ways" group will actually ignore all"crossing XXX" groups silently too

The patch 16978.patch uses a distinct code number for each group in CrossingWays and UnconnectedWays.

I think it would be good to have a dialog that allows to edit/reset the content of the ignorederrors file. It would also help to have a descriptive text for the numbers.

comment:3 Changed 5 months ago by GerdP

I think this can be committed as is. My experience with dialogs is too small.

comment:4 Changed 5 months ago by Don-vip

Looks good. I would only remove the super(); statement which is not needed. Also the @since xxx must be updated when the patch is applied.

comment:5 Changed 5 months ago by Don-vip

Milestone: 18.12

comment:6 Changed 5 months ago by GerdP

Resolution: fixed
Status: newclosed

In 14468/josm:

fix #16978 Use distinct code number for each test group in CrossingWays and UnconnectedWays

comment:7 Changed 5 months ago by bagage

It seemed to work great at first, but there might be a bug:

  1. Click "Validate" button on some OSM data (for instance France city "Les Cluses")
  2. Ignore some groups, for instance "deprecated wood=deciduous" or "building/residential area are crossing"

--> These groups are removed as expected, OK and appended to the ignorederrors file:

3000_*[wood=deciduous]
614
  1. Click "Validate" button again: these errors pop back!

comment:8 Changed 5 months ago by GerdP

I cannot reproducde that on my machine. What do you do between 2. and 3.?

comment:9 Changed 5 months ago by bagage

Oh indeed! I unselected everything from the map. Here's an animated demo https://my.mixtape.moe/ouzspf.webm

You can actually see that some things are inconsistent: at first there are 212 warnings (incl. 2 wood + 2 buildings). Then after ignoring both of them and revalidating, I've got 210 warnings (I would expect 208 here).

Note: I built JOSM on my machine if that matters. I emptied the ignorederrors file first, then closed JOSM, then did the 1/2/3 steps on "Les Cluses" city. JOSM 14512.

Last edited 5 months ago by bagage (previous) (diff)

comment:10 Changed 5 months ago by GerdP

I can see what you mean but I still cannot reproduce it. Maybe you have a lock on the ignorederrors file?
The number of warnings can change when you check only selected members. For example, the selection doesn't contain the ways
with power=line, only the nodes which are not tagged power=tower/pole.

comment:11 Changed 5 months ago by bagage

OK indeed that makes sense. I've tested with JOSM-latest.jar from website and it works great. I'm not confident about SVN (definitely looking for git transition :)), but I believe I have some local modifications... sorry for the noise, and thanks GerdP for fixing that really annoying bug (for me at least!). Cheers!

comment:12 Changed 5 months ago by GerdP

OK, great. My svn client is configured to restore the date when a file was checked in. So when I revert changes with svn revert I have to use ant clean to make sure that files are rebuild.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.