Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13800 closed defect (fixed)

Validation not possible - IllegalArgumentException

Reported by: anonymous Owned by: team
Priority: blocker Milestone: 16.10
Component: Core validator Version: latest
Keywords: regression Cc: simon04

Description

Load data and start validation.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-10-15 00:17:47 +0200 (Sat, 15 Oct 2016)
Build-Date:2016-10-15 01:33:13
Revision:11129
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11129 de) Linux Debian GNU/Linux 8.6 (jessie)
Memory Usage: 686 MB / 1600 MB (245 MB allocated, but free)
Java version: 1.8.0_102-8u102-b14.1-1~bpo8+1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-8-jre:amd64-8u102-b14.1-1~bpo8+1
Dataset consistency test: No problems found

=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: primitives already set
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureThat(CheckParameterUtil.java:105)
	at org.openstreetmap.josm.data.validation.TestError$Builder.primitives(TestError.java:141)
	at org.openstreetmap.josm.data.validation.TestError$Builder.primitives(TestError.java:131)
	at org.openstreetmap.josm.data.validation.tests.Addresses.checkHouseNumbersWithoutStreet(Addresses.java:103)
	at org.openstreetmap.josm.data.validation.tests.Addresses.visit(Addresses.java:115)
	at org.openstreetmap.josm.data.osm.Way.accept(Way.java:211)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:211)
	at org.openstreetmap.josm.actions.ValidateAction$ValidationTask.realRun(ValidateAction.java:166)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (11)

comment:1 Changed 3 years ago by anonymous

Minimal test:

<?xml version='1.0' encoding='UTF-8'?>
<osm version='0.6' upload='true' generator='JOSM'>
  <node id='-10000' action='modify' visible='true' lat='1.00000000000' lon='1.00000000000'>
    <tag k='addr:housenumber' v='1' />
    <tag k='survey:date' v='2016-10-01' />
  </node>
</osm>

comment:2 Changed 3 years ago by anonymous

Priority: normalmajor
Summary: IllegalArgumentExceptionValidation not possible - IllegalArgumentException

Only upload without validation is possible.

comment:3 Changed 3 years ago by anonymous

survey:date does not make a difference.
Also this test fails:

<?xml version='1.0' encoding='UTF-8'?>
<osm version='0.6' upload='true' generator='JOSM'>
  <node id='-10000' action='modify' visible='true' lat='1.00000000000' lon='1.00000000000'>
    <tag k='addr:housenumber' v='1' />
  </node>
</osm>

comment:4 Changed 3 years ago by hjart

I would classify this one as a blocker, as it won't even let me upload.

comment:5 Changed 3 years ago by anonymous

Priority: majorblocker

comment:6 Changed 3 years ago by Klumbumbus

Cc: simon04 added
Keywords: regression added
Milestone: 16.10

comment:7 Changed 3 years ago by anonymous

Priority: majorblocker

comment:8 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 11130/josm:

fix #13800 see #13799 - Fix IAE in TestError

comment:9 Changed 3 years ago by simon04

Sorry. Introducing argument checks right before committing w/o testing is not the best idea. :/

comment:10 Changed 3 years ago by Klumbumbus

Ticket #13802 has been marked as a duplicate of this ticket.

comment:11 Changed 3 years ago by Klumbumbus

Ticket #13803 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.