Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13803 closed defect (duplicate)

Crash when trying to upload

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Was editing map, wanted to upload it
  2. Clicked "Upload data"
  3. Got this crash

What is the expected result?

No crash

What happens instead?

Crash

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-10-15 00:17:47 +0200 (Sat, 15 Oct 2016)
Build-Date:2016-10-15 01:33:13
Revision:11129
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11129 en) Windows XP 32-Bit
Memory Usage: 563 MB / 989 MB (186 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1600x1200, \Display1 1600x1200
Maximum Screen Size: 1600x1200
Dataset consistency test: No problems found

Plugins:
+ ColorPlugin (11)
+ DirectDownload (32699)
+ DirectUpload (32699)
+ colorscheme (32699)
+ continuosDownload (53)
+ download_along (32946)
+ editgpx (32699)
+ imagery_offset_db (32796)
+ pbf (32865)
+ reltoolbox (32796)
+ reverter (32796)
+ utilsplugin2 (32815)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&zip=1
+ C:\Program Files\JOSM\Styles_Power-style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/OsmcSKCZPL&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1

Last errors/warnings:
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- E: IO Exception - <html>Failed to upload data to or download data from<br>'http://overpass.osm.rambler.ru/cgi/interpreter?data=%5Bout%3Axml%5D%5Btimeout%3A25%5D%5Bbbox%3A50.1103011%2C14.7815486%2C50.5896276%2C15.5210658%5D%3B%0A%28%0A++node%5B%22power%22%5D%3B%0A++way%5B%22power%22%5D%3B%0A++relation%5B%22power%22%5D%3B%0A%29%3B%0A%28._%3B%3E%3B%29%3B%0Aout+meta%3B'<br>due to a problem with transferring data.<br>Details (untranslated): Read timed out</html>
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.conflict.tags.PasteTagsConflictResolverDialog$ApplyAction@162adcd
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.conflict.tags.PasteTagsConflictResolverDialog$CancelAction@269638
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.conflict.tags.PasteTagsConflictResolverDialog$ApplyAction@e0d6f4
- W: Old style SideButton usage for action org.openstreetmap.josm.gui.conflict.tags.PasteTagsConflictResolverDialog$CancelAction@18d252


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: primitives already set
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureThat(CheckParameterUtil.java:105)
	at org.openstreetmap.josm.data.validation.TestError$Builder.primitives(TestError.java:141)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker$TagCheck.getErrorForPrimitive(MapCSSTagChecker.java:585)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:688)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.getErrorsForPrimitive(MapCSSTagChecker.java:673)
	at org.openstreetmap.josm.data.validation.tests.MapCSSTagChecker.check(MapCSSTagChecker.java:705)
	at org.openstreetmap.josm.data.validation.Test$TagTest.visit(Test.java:123)
	at org.openstreetmap.josm.data.osm.Node.accept(Node.java:230)
	at org.openstreetmap.josm.data.validation.Test.visit(Test.java:211)
	at org.openstreetmap.josm.actions.upload.ValidateUploadHook.checkUpload(ValidateUploadHook.java:61)
	at org.openstreetmap.josm.actions.UploadAction.checkPreUploadConditions(UploadAction.java:207)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:231)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:271)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13800.

comment:2 Changed 4 years ago by skyper

Component: CoreCore validator

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.