Modify

Opened 3 years ago

Closed 3 years ago

#13767 closed enhancement (fixed)

Asynchronous initializations for more reactive UI

Reported by: simon04 Owned by: simon04
Priority: normal Milestone: 16.10
Component: Core Version:
Keywords: Cc: responsive, initialization

Description

Imagery, validator, OverpassTurbo wizard are currently initialised upon first usage. This causes an unexpected program un-responsiveness e.g. when uploading changed (since the changes are validated).

After the essential things have been initialised on program start, some non essential things can be initialised in the background.

Attachments (0)

Change History (7)

comment:1 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 11092/josm:

fix #13767 - Asynchronous initializations for more reactive UI

comment:2 Changed 3 years ago by Don-vip

nice :)

comment:3 Changed 3 years ago by Klumbumbus

Ticket #13772 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Klumbumbus

Could this also be done for creation of a new layer? The creation of the first new data layer after starting josm takes longer than the second layer (after closing the first one).

comment:5 Changed 3 years ago by HarryKane

Resolution: fixed
Status: closedreopened

comment:6 Changed 3 years ago by HarryKane

I tried again in latest JOSM 11223, but the problem is still there.

Steps to reproduce:

  1. Download a layer, have the continuous download plug-in option enabled.
  2. Zoom out a bit, so JOSM downloads new surrounding areas.
  3. Click the download button again to specify a new area.

You might ask why one does step 3. The reason is that either
a) the download of step 2 takes too long so the user wants to speed up this process by searching the new area (especially when GPS tracks are downloaded) or
b) the user wants to download another area.

In all these cases JOSM is very slow on reacting to the users input and thus hampers the workflow.

comment:7 in reply to:  6 Changed 3 years ago by simon04

Resolution: fixed
Status: reopenedclosed

This seems unrelated to the enhancement done in this ticket. I created a new ticket for comment:6#14018

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.