Modify

Opened 6 years ago

Closed 6 years ago

#13772 closed defect (duplicate)

Provide immediate visual feedback on data validation or OSM queries

Reported by: HarryKane Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

How to reproduce:

  1. Load an area into JOSM.
  2. Load another area into JOSM, click the data validation button or query the notes.

Expected result:
Show immediate feedback that JOSM does the desired action, even if it takes a while to come up with results.

Actual result:
JOSM provides no immediate feedback, sometimes for a minute or so. This lets the user assume that the request isn't executed, so she tries again and again. When JOSM finally gets a response or starts validating the data, it does this many times on and on until all - including the unnecessary - requests are fulfilled. This is time consuming and confusing.

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Klumbumbus

I think this is already fixed in #13767. The validator now immediately displays the progress window once the validation button was clicked.

comment:2 Changed 6 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13767.
Please reopen if there is still a probelm with version >11092

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.