Modify

Opened 8 years ago

Closed 6 years ago

#13561 closed defect (fixed)

Can't go out of "Adjust imagery offset" even after pressing Ok or Cancel and dialog disappeared.

Reported by: mrjones Owned by: team
Priority: normal Milestone: 18.05
Component: Core imagery Version: tested
Keywords: template_report, regression, gsoc-core, offset Cc: michael2402, PT-53, kksrally@…, dido, Beddhist

Description

What steps will reproduce the problem?

  1. After opening JOSM load Bing imagery
  2. Right click on the "Bing aerial imagery" on the layers pane and select "Offset"
  3. After correcting the offset, press Ok.
  4. Even though the dialog disappeared, we are still in it. We can't select anything of our Data Layer. When activating any layer the dialog comes back.

What is the expected result?

The offset to be set so we can do our edits.

What happens instead?

The offset seems to be locked up and we can't not go out of it.

Please provide any additional information below. Attach a screenshot if possible.

The problem did not happen in the previous version.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en) Windows 10 64-Bit
Memory Usage: 477 MB / 910 MB (155 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (32699)
+ FastDraw (32773)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ PicLayer (32796)
+ apache-commons (32699)
+ buildings_tools (32796)
+ ejml (32680)
+ ext_tools (32796)
+ geotools (32813)
+ importvec (32699)
+ jts (32699)
+ opendata (32898)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)

Tagging presets:
+ http://maps.openstreetmap.ie/josm/irishboundaries.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
+ %UserProfile%\Pictures\Screenshots\townland.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (0)

Change History (26)

comment:1 by Klumbumbus, 8 years ago

Keywords: regression gsoc-core added
Milestone: 16.09

Until this is fixed you can use the following workaround: after closing the adjust imagery window with ok switch to draw mode (A)

comment:2 by Don-vip, 8 years ago

Cc: michael2402 added

comment:3 by Klumbumbus, 8 years ago

Ticket #13616 has been marked as a duplicate of this ticket.

comment:4 by Klumbumbus, 8 years ago

Cc: PT-53 added
Component: CoreCore imagery

comment:5 by Klumbumbus, 8 years ago

Ticket #13647 has been marked as a duplicate of this ticket.

comment:6 by Klumbumbus, 8 years ago

Cc: kksrally@… added
Version: latesttested

comment:7 by aceman, 8 years ago

Confirming the problem. Still in 11020.

comment:8 by Klumbumbus, 8 years ago

Ticket #13697 has been marked as a duplicate of this ticket.

comment:9 by Klumbumbus, 8 years ago

Cc: dido added
Priority: normalcritical

comment:10 by simon04, 8 years ago

Regression of r10930.

comment:11 by simon04, 8 years ago

Resolution: fixed
Status: newclosed

In 11063/josm:

fix #13561 - Cannot go out of "Adjust imagery offset" even after pressing Ok or Cancel and dialog disappeared

comment:12 by simon04, 8 years ago

Resolution: fixed
Status: closedreopened

This is still a bit fishy:

  1. Add Bing layer, but no data layer
  2. Adjust imagery offset
  3. Close dialog

→ You are still in the adjusting mode.

And:

  1. Add Bing layer, but no data layer
  2. Adjust imagery offset
  3. Close dialog
  4. Add data layer

→ Now the dialog pops up again

And:

  1. Add Bing layer, but no data layer
  2. Adjust imagery offset
  3. Close dialog
  4. Click again on "Adjust imagery offset"

→ You cannot enter the adjustment mode

And:

  1. Add Bing layer, but no data layer
  2. Adjust imagery offset
  3. Press ESC to close the dialog

→ The offset is applied (in contrast to pressing cancel)

comment:13 by simon04, 8 years ago

Milestone: 16.0916.10

Milestone renamed

comment:14 by Beddhist, 8 years ago

Another workaround: press S to go into selection mode, the cursor changes from a pointer/hand to pointer/box.

comment:15 by Beddhist, 8 years ago

Cc: Beddhist added

comment:16 by simon04, 8 years ago

Milestone: 16.1016.11

comment:17 by Don-vip, 7 years ago

Milestone: 16.1116.12

Milestone renamed

comment:18 by Don-vip, 7 years ago

Milestone: 16.1217.01
Priority: criticalmajor

comment:19 by Don-vip, 7 years ago

Milestone: 17.0117.02

comment:20 by Don-vip, 7 years ago

Milestone: 17.0217.03

comment:21 by Stereo, 7 years ago

Ticket #11112 has been marked as a duplicate of this ticket.

comment:22 by Don-vip, 7 years ago

Milestone: 17.03
Priority: majornormal

comment:23 by Don-vip, 7 years ago

Keywords: offset added

comment:24 by Klumbumbus, 6 years ago

The 4 special cases from comment:12 are all fixed meanwhile. The only minor issue left which I noticed is:

When you align the bing layer when it is the active layer the align dialog pops up everytime this layer becomes the active one again (e.g., by setting the green checkmark in the layer list or by deleting all other layers)

comment:25 by Don-vip, 6 years ago

Milestone: 18.05

comment:26 by Don-vip, 6 years ago

Resolution: fixed
Status: reopenedclosed

In 13795/josm:

fix #13561, fix #16265 - fix mapmode change issues with "Adjust imagery offset"

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.