Modify

Opened 7 years ago

Closed 5 years ago

#11112 closed defect (duplicate)

OSX: Adjust imagery offset dialog appears when switching layers

Reported by: ar2988-os@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report macosx Cc:

Description

Unfortunately this bug only appears about 50% of the time when using imagery and I have not discovered the exact sequence of actions which produces it.

What steps will reproduce the problem?

  1. Use JOSM with multiple layers
  2. Load Bing imagery
  3. Adjust the imagery offset for the Bing layer
  4. Edit the data, switch layers, hide and show the Bing layer, etc.
  5. Show the Bing layer then select a data layer. One of these clicks may cause the Adjust imagery offset dialog to appear. Once this dialog has appeared in this way, it will continue to appear frequently when clicking in the layers panel, until you quit JOSM.

What is the expected result?

The Adjust imagery offset dialog only appears when you choose it

Please provide any additional information below. Attach a screenshot if possible.

This is a long-standing bug - a regression which occurred more than two years ago.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2015-02-01 02:33:54
Last Changed Author: Don-vip
Revision: 7995
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Relative URL: ^/trunk
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2015-01-31 15:17:59 +0100 (Sat, 31 Jan 2015)
Last Changed Rev: 7995

Identification: JOSM/1.5 (7995 en) Mac OS X 10.9.5
Memory Usage: 737 MB / 3641 MB (395 MB allocated, but free)
Java version: 1.7.0_75, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (30892)
- InfoMode (30892)
- PicLayer (30892)
- cadastre-fr (30892)
- download_along (30892)
- editgpx (30892)
- geotools (30892)
- imagery_offset_db (30892)
- jts (30892)
- log4j (30892)
- measurement (30892)
- opendata (30911)
- poly (30892)
- reverter (30892)
- turnrestrictions (30892)
- undelete (30892)
- utilsplugin2 (30892)
- waydownloader (30892)

Last errors/warnings:
- W: TMS - Failed downloading http://ecn.t2.tiles.virtualearth.net/tiles/a120222122311121300.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t2.tiles.virtualearth.net/tiles/a120222122311121230.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t1.tiles.virtualearth.net/tiles/a120222122311121212.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t1.tiles.virtualearth.net/tiles/a120222122311121322.jpeg?g=3262: Attribution is not loaded yet
- W: TMS - Failed downloading http://ecn.t3.tiles.virtualearth.net/tiles/a120222122311121232.jpeg?g=3262: Attribution is not loaded yet

Attachments (0)

Change History (4)

comment:1 Changed 7 years ago by Don-vip

Keywords: macosx added
Summary: Adjust imagery offset dialog appears when switching layersOSX: Adjust imagery offset dialog appears when switching layers

comment:2 Changed 5 years ago by Stereo

Hi, are you still seeing this bug? I can't reproduce it, and can't say it's ever happened to me.

comment:3 Changed 5 years ago by ar2988-os@…

I have not seen this bug recently. It may have been fixed in ticket:13561#comment:11 although simon04 was not entirely happy with the fix.

comment:4 Changed 5 years ago by Stereo

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13561.
Thanks, that is probably indeed the case. I'll mark it as duplicate then.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.