Modify

Opened 3 years ago

Closed 3 years ago

#13397 closed defect (fixed)

[Patch] There is not a plus sign in the middle of some lines to add a point. Midpoint

Reported by: maxphizik@… Owned by: team
Priority: major Milestone: 16.08
Component: Core mappaint Version: latest
Keywords: template_report regression gsoc-core Cc: michael2402

Description (last modified by Don-vip)

Approximately 30% of lines has not a plus sign in the middle of some lines to add a point.

Please provide any additional information below. Attach a screenshot if possible.

screenshot

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-21 03:15:12 +0200 (Sun, 21 Aug 2016)
Build-Date:2016-08-21 01:38:47
Revision:10865
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10865 ru) Windows 10 64-Bit
Memory Usage: 1794 MB / 6372 MB (581 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
+ CommandLine (32796)
+ FastDraw (32773)
+ HouseNumberTaggingTool (32699)
+ PicLayer (32796)
+ buildings_tools (32796)
+ imagery_offset_db (32796)
+ measurement (32732)
+ reltoolbox (32796)
+ reverter (32796)
+ utilsplugin2 (32815)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (2)

Безымянный.jpg (31.4 KB) - added by maxphizik@… 3 years ago.
screenshot
patch-fix-13397.patch (5.2 KB) - added by michael2402 3 years ago.

Download all attachments as: .zip

Change History (13)

Changed 3 years ago by maxphizik@…

Attachment: Безымянный.jpg added

screenshot

comment:1 Changed 3 years ago by Don-vip

Description: modified (diff)

comment:2 Changed 3 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 3 years ago by Don-vip

Keywords: regression added
Milestone: 16.08
Priority: normalmajor

comment:4 Changed 3 years ago by Don-vip

r10823 => OK
r10836 => BUG

comment:5 Changed 3 years ago by Don-vip

Cc: michael2402 added
Keywords: gsoc-core added

Sounds like a regression of r10827 or r10824

comment:6 Changed 3 years ago by michael2402

Yes. There was a parentheses missing. I also changed the flags to be real flag values and added tests for it.

Changed 3 years ago by michael2402

Attachment: patch-fix-13397.patch added

comment:7 Changed 3 years ago by michael2402

Summary: There is not a plus sign in the middle of some lines to add a point.[Patch] There is not a plus sign in the middle of some lines to add a point.

comment:8 Changed 3 years ago by Klumbumbus

Ticket #13401 has been marked as a duplicate of this ticket.

comment:9 Changed 3 years ago by Klumbumbus

Component: CoreCore mappaint

comment:10 Changed 3 years ago by Hb---

Summary: [Patch] There is not a plus sign in the middle of some lines to add a point.[Patch] There is not a plus sign in the middle of some lines to add a point. Midpoint

comment:11 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10867/josm:

fix #13397 - segment did not display anymore middle plus signs (patch by michael2402) - regression of r10827 or r10824 - gsoc-core

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.