Modify

Opened 4 years ago

Closed 4 years ago

#13252 closed defect (duplicate)

unexpected error occurered

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin shapetools Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. select way
  2. crash notice

What is the expected result?

Way is selected

What happens instead?

get a notice "An unexpected exception occurred."

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-30 18:11:49 +0200 (Sat, 30 Jul 2016)
Build-Date:2016-07-31 01:51:41
Revision:10681
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10681 en) Linux Fedora release 24 (Twenty Four)
Memory Usage: 1202 MB / 7150 MB (583 MB allocated, but free)
Java version: 1.8.0_101-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: java-1.8.0-openjdk:x86_64-1.8.0.101
Dataset consistency test: No problems found

Plugins:
- ImportImagePlugin (32584)
- InfoMode (32491)
- Mapillary (32639)
- OpeningHoursEditor (32583)
- ShapeTools (1010)
- alignways (32466)
- apache-commons (32584)
- apache-http (32584)
- buildings_tools (32728)
- ejml (32639)
- geochat (32561)
- geotools (32584)
- jts (32539)
- log4j (32309)
- measurement (32732)
- opendata (32584)
- pbf (32584)
- pdfimport (32584)
- public_transport (32639)
- routes (32456)
- splinex (32584)
- undelete (32584)
- utilsplugin2 (32725)
- wikipedia (32671)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Last errors/warnings:
- W: Invalid jar file ''<josm.pref>/plugins/measurement.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>/plugins/utilsplugin2.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>/plugins/buildings_tools.jar.new'' (exists: false, canRead: false)
- E: java.lang.NoSuchFieldError: isUsablePredicate
- E: java.lang.NoSuchFieldError: isUsablePredicate
- E: java.lang.NoSuchFieldError: isUsablePredicate
- E: java.lang.NoSuchFieldError: isUsablePredicate
- E: java.lang.NoSuchFieldError: isUsablePredicate


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NoSuchFieldError: isUsablePredicate
	at org.openstreetmap.josm.plugins.shapetools.ShapeMode.mouseClicked(ShapeMode.java:42)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:269)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:269)
	at java.awt.Component.processMouseEvent(Component.java:6536)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4534)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by Don-vip

Component: CorePlugin shapetools

comment:2 Changed 4 years ago by Don-vip

Ticket #13323 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13285.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.