Modify

Opened 5 years ago

Closed 5 years ago

#13058 closed defect (fixed)

Impossible to close JOSM main window - The painter for layer OsmDataLayer was not registered

Reported by: slodki Owned by: slodki
Priority: major Milestone: 16.06
Component: Core imagery Version: latest
Keywords: OsmDataLayer painter MapView.layerRemoving gsoc-core regression Cc:

Description

What steps will reproduce the problem?

  1. Do some editing work
  2. Upload changes to server
  3. Click on [x] button to close main JOSM window

What is the expected result?

Close JOSM window and exit.

What happens instead?

Error pop-up, skip error closes pop-up, but click on [x] shows it again... and close JOSM is not possible.
Similar error is triggered when trying to activate different layer or select Exit from menu.
After killing JOSM this problem is not reproducible.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-24 01:49:51 +0200 (Fri, 24 Jun 2016)
Build-Date:2016-06-24 01:34:30
Revision:10473
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10473 pl) Linux Slackware 14.2
Memory Usage: 951 MB / 951 MB (456 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, OpenJDK Server VM

Plugins:
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- Tracer2 (32158)
- buildings_tools (32158)
- measurement (32324)
- public_transport (32158)
- reverter (32158)
- turnlanes (32158)
- turnrestrictions (32386)
- undelete (32158)
- utilsplugin2 (32158)
- wikipedia (32182)

Tagging presets:
- http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/current/roofspresets.xml
- https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/maxspeed_PL&preset&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&style&zip=1

Last errors/warnings:
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.. Przyczyna: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.. Przyczyna: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.. Przyczyna: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.. Przyczyna: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.. Przyczyna: java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.

=== REPORTED CRASH DATA ===
LayerManager#fireLayerRemoving:
 - listener: org.openstreetmap.josm.gui.MapView[,0,0,899x879,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=java.awt.Dimension[width=10,height=0],preferredSize=]
 - event: LayerRemoveEvent [removedLayer=org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de, lastLayer=false]

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
java.lang.IllegalArgumentException: The painter for layer org.openstreetmap.josm.gui.layer.OsmDataLayer@4131de was not registered.
	at org.openstreetmap.josm.gui.MapView.layerRemoving(MapView.java:700)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerRemoving(LayerManager.java:372)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:202)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveLayer(MainLayerManager.java:215)
	at org.openstreetmap.josm.gui.layer.LayerManager$2.run(LayerManager.java:194)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:146)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:191)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:398)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.resetState(MainLayerManager.java:318)
	at org.openstreetmap.josm.Main.shutdown(Main.java:1179)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:117)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:1160)
	at org.openstreetmap.josm.gui.MainFrame$3.windowClosing(MainFrame.java:105)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.Window.processWindowEvent(Window.java:2058)
	at javax.swing.JFrame.processWindowEvent(JFrame.java:304)
	at java.awt.Window.processEvent(Window.java:2017)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by malenki

Confirm with r10473:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-24 01:49:51 +0200 (Fri, 24 Jun 2016)
Build-Date:2016-06-24 01:34:30
Revision:10473
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10473 de) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 711 MB / 2222 MB (502 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=false]

Plugins:
- FastDraw (32158)
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- ImportImagePlugin (32287)
- InfoMode (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- ShapeTools (1000)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- continuosDownload (53)
- contourmerge (1014)
- download_along (32158)
- ejml (32158)
- ext_tools (32158)
- geotools (31895)
- gson (32158)
- imagery_offset_db (32158)
- jts (31906)
- log4j (32158)
- mapdust (31923)
- measurement (32324)
- opendata (32289)
- photo_geotagging (32158)
- photoadjust (32158)
- reltoolbox (32158)
- reverter (32158)
- tag2link (31923)
- tageditor (32158)
- terracer (32158)
- todo (29154)
- turnrestrictions (32375)
- undelete (32158)
- utilsplugin2 (32158)
- waydownloader (32158)
- wikipedia (32182)

Tagging presets:
- http://www.country-linedance.de/daten/Archaeologie-de.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Czech_hiking&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Leaftype&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/SentieriItaliani&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LitObjects&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Osmc&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/OsmcSKCZPL&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@1fdd838e
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@41f93316
- E: java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@634c75b6
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: Attempted to remove listener that was not in list: org.openstreetmap.josm.gui.dialogs.relation.SelectionTableModel@4aacc529. Ursache: java.lang.IllegalArgumentException: Attempted to remove listener that was not in list: org.openstreetmap.josm.gui.dialogs.relation.SelectionTableModel@4aacc529
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.. Ursache: java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.

=== REPORTED CRASH DATA ===
MapView#paintLayer:
 - layer: org.openstreetmap.josm.gui.layer.OsmDataLayer@3bb126e3
 - bounds: Bounds[50.9299456,13.5056638,50.9378093,13.5201422]

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:785)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:857)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:290)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

comment:2 Changed 5 years ago by Don-vip

Cc: wiktorn michael2402 removed
Keywords: gsoc-core regression added
Milestone: 16.06
Owner: changed from team to michael2402

comment:3 Changed 5 years ago by michael2402

There seems to be a redraw triggered after MapView.destroy() was called... I'll have a look at it.

comment:4 Changed 5 years ago by rickmastfan67

I also triggered this with the following steps mentioned in #13051. However, in r10485, I couldn't trigger it again after the main part of #13051 was fixed.

comment:5 Changed 5 years ago by michael2402

@malenki: Your error should be fixed in the current version.

@slodki: I could not reproduce this issue either. Do you know anything you did before the error appeared (adding a specific layer, some popup appearing, ...)?

comment:6 Changed 5 years ago by michael2402

Owner: changed from michael2402 to slodki
Status: newneedinfo

comment:7 Changed 5 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

Looks fixed. Please reopen if reproduced.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain slodki.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.