Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13059 closed defect (duplicate)

relation editor remembers discarded change

Reported by: malenki Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report relation Cc:

Description

What steps will reproduce the problem?

  1. Have a relation at hand.
  2. Open it in the relation editor
  3. Make any edit on it (add a tag, add or remove a member)
  4. Click "cancel" and then "discard changes"
  5. Now open the relation editor for that relation again and clicking "cancel" again.

What is the expected result?

Relation editor closes

What happens instead?

The user again is asked if he wants to keep or discard the changes although none were made.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-24 01:49:51 +0200 (Fri, 24 Jun 2016)
Build-Date:2016-06-24 01:34:30
Revision:10473
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10473 de) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 397 MB / 2222 MB (289 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=false]
Dataset consistency test: No problems found


Last errors/warnings:
- W: Ungespeicherte Änderungen - <html>Die Relation wurde geändert.<br><br>Wollen Sie die Änderungen speichern?</html>
- E: java.lang.IllegalArgumentException: Attempted to remove listener that was not in list: org.openstreetmap.josm.gui.dialogs.relation.SelectionTableModel@6a92ee4f
- W: Ungespeicherte Änderungen - <html>Die Relation wurde geändert.<br><br>Wollen Sie die Änderungen speichern?</html>
- E: java.lang.IllegalArgumentException: Attempted to remove listener that was not in list: org.openstreetmap.josm.gui.dialogs.relation.SelectionTableModel@6a92ee4f
- W: Ungespeicherte Änderungen - <html>Die Relation wurde geändert.<br><br>Wollen Sie die Änderungen speichern?</html>

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by malenki

Resolution: fixed
Status: newclosed

Obviously this issue got fixed with the latest patches.

comment:2 Changed 5 years ago by Don-vip

Resolution: fixedduplicate

dupe of #13164

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.