Modify

Opened 5 years ago

Closed 5 years ago

#13051 closed defect (duplicate)

java.lang.IllegalArgumentException w/ ZoomToAction

Reported by: rickmastfan67 Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Steps to reproduce:

  1. Download an area that has a relation in it.
  2. Select any 'incomplete' relation from the relations window.
  3. Click the button in the relation window to edit the relation.
  4. Hit the 'Cancel' button.

What happens:
JOSM crashes.

What should happen:
JOSM shouldn't crash.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-24 01:49:51 +0200 (Fri, 24 Jun 2016)
Build-Date:2016-06-24 01:34:30
Revision:10473
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10473 en) Windows 7 64-Bit
Memory Usage: 573 MB / 1820 MB (110 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (32158)
- buildings_tools (32158)
- measurement (32324)
- osmarender (31772)
- reverter (32158)
- turnlanes-tagging (1466175713)
- turnrestrictions (32375)
- undelete (32158)
- utilsplugin2 (32158)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: Unable to delete file %UserProfile%\OSM-Tiles\TMS_INDEX_v2.data
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$NewAction@1de52ed9
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$EditAction@bd66f37
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$DeleteAction@71006cee
- E: java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@2638c3c

java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@2638c3c
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:345)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:333)
	at org.openstreetmap.josm.gui.widgets.OsmPrimitivesTable.unregisterListeners(OsmPrimitivesTable.java:105)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTable.unregisterListeners(MemberTable.java:142)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.setVisible(GenericRelationEditor.java:758)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.SavingAction.hideEditor(SavingAction.java:191)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.CancelAction.actionPerformed(CancelAction.java:73)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Also, when you leave the bug report window, and attempt to close JOSM by hitting the red 'X' in Windows, JOSM crashes again and prohibits you from leaving the program. You are forced to crash it via the task manager, hence the 'critical' priority, but could be upgraded to 'blocker'.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-24 01:49:51 +0200 (Fri, 24 Jun 2016)
Build-Date:2016-06-24 01:34:30
Revision:10473
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10473 en) Windows 7 64-Bit
Memory Usage: 578 MB / 1820 MB (444 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- OpeningHoursEditor (32158)
- buildings_tools (32158)
- measurement (32324)
- osmarender (31772)
- reverter (32158)
- turnlanes-tagging (1466175713)
- turnrestrictions (32375)
- undelete (32158)
- utilsplugin2 (32158)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$EditAction@bd66f37
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$DeleteAction@71006cee
- E: java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@2638c3c
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: Attempted to remove listener that was not in list: org.openstreetmap.josm.gui.dialogs.relation.SelectionTableModel@b9c5f78. Cause: java.lang.IllegalArgumentException: Attempted to remove listener that was not in list: org.openstreetmap.josm.gui.dialogs.relation.SelectionTableModel@b9c5f78
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.. Cause: java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.

=== REPORTED CRASH DATA ===
MapView#paintLayer:
 - layer: org.openstreetmap.josm.gui.layer.OsmDataLayer@5c133a3c
 - bounds: Bounds[43.9121183,-79.1101893,43.9234891,-79.0855542]

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: Cannot paint layer, it is not registered.
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:785)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:857)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1200(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by stoecker

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13040.
If the second issue remains with tomorrows latest, please reopen. The first one is clearly a duplicate.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.