Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13040 closed defect (fixed)

IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction

Reported by: naoliv Owned by: michael2402
Priority: normal Milestone: 16.06
Component: Core Version:
Keywords: gsoc-core Cc:

Description

I am unsure if I just clicked somewhere or if I moved the scroll to zoom, but:

ERRO: java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@576f07b7
java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@576f07b7
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:342)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:330)
	at org.openstreetmap.josm.gui.widgets.OsmPrimitivesTable.unregisterListeners(OsmPrimitivesTable.java:105)
	at org.openstreetmap.josm.gui.dialogs.relation.MemberTable.unregisterListeners(MemberTable.java:142)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.setVisible(GenericRelationEditor.java:758)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.SavingAction.hideEditor(SavingAction.java:191)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.OKAction.actionPerformed(OKAction.java:46)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6535)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6300)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-23 02:35:10 +0200 (Thu, 23 Jun 2016)
Build-Date:2016-06-23 01:34:05
Revision:10463
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10463 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 416 MB / 10206 MB (71 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-2-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- RoadSigns (32177)
- SimplifyArea (32158)
- apache-commons (32158)
- buildings_tools (32158)
- conflation (0.2.0)
- contourmerge (1014)
- download_along (32158)
- editgpx (32263)
- ejml (32158)
- geotools (31895)
- imagery_offset_db (32158)
- importvec (32287)
- indoorhelper (32158)
- jts (31906)
- log4j (32158)
- measurement (32324)
- merge-overlap (32158)
- opendata (32289)
- pbf (32290)
- pdfimport (32158)
- poly (32287)
- reverter (32158)
- scripting (30723)
- todo (29154)
- turnrestrictions (32375)
- undelete (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1

Map paint styles:
- <josm.pref>/styles/indoor.mapcss
- /tmp/bla-style.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1

Validator rules:
- /arquivos/git/validador-josm/Rules_Brazilian-Specific.validator.mapcss
- /arquivos/git/validador-josm/staging.validator.mapcss
- <josm.pref>/validator/indoorhelper.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: java.lang.IllegalArgumentException: Listener was not registered before: org.openstreetmap.josm.actions.ZoomToAction@576f07b7

Attachments (1)

patch-fix-13040.patch (1.3 KB) - added by michael2402 3 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 3 years ago by naoliv

And it seems that I can reproduce it:

  • select a relation and enter the relation editor (it's not necessary to modify anything)
  • quit the editor
  • try to zoom

comment:2 Changed 3 years ago by Don-vip

Milestone: 16.06

comment:3 Changed 3 years ago by michael2402

This one was missed in [10454] because that listener was never registered.

The patch fixes it and registers the listener.

Changed 3 years ago by michael2402

Attachment: patch-fix-13040.patch added

comment:4 Changed 3 years ago by stoecker

Resolution: fixed
Status: newclosed

In 10478/josm:

fix #13040 - patch by Michael Zangl - gsoc-core - fix exception

comment:5 Changed 3 years ago by stoecker

Ticket #13051 has been marked as a duplicate of this ticket.

comment:6 Changed 3 years ago by stoecker

Ticket #13053 has been marked as a duplicate of this ticket.

comment:7 Changed 3 years ago by stoecker

Ticket #13055 has been marked as a duplicate of this ticket.

comment:8 Changed 3 years ago by Don-vip

Ticket #13080 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain michael2402.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.