Modify

Opened 5 years ago

Closed 5 years ago

#12972 closed defect (duplicate)

NullPointerException when loading WMS imagery layer

Reported by: mhohmann Owned by: team
Priority: major Milestone:
Component: Core imagery Version: latest
Keywords: imagery, wms, NullPointerException Cc:

Description

What steps will reproduce the problem?

  1. Load some data (in my case, in Estonia).
  2. Switch on an imagery layer (in my case, Estonia Ortho, which is WMS).

What is the expected result?

The imagery layer should be displayed.

What happens instead?

Nothing is displayed and JOSM issues a crash / bug message every few seconds.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-14 22:25:40 +0200 (Tue, 14 Jun 2016)
Build-Date:2016-06-15 01:34:12
Revision:10377
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10377 en) Linux Ubuntu 16.04 LTS
Memory Usage: 291 MB / 910 MB (64 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (32158)
- FixAddresses (32158)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- download_along (32158)
- measurement (32158)
- reverter (32158)
- terracer (32158)
- utilsplugin2 (32158)
- walkingpapers (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/Light_sources&zip=1

Map paint styles:
- /data/Maps/Styles/standard.mapcss
- /data/Maps/Styles/tmc.mapcss
- http://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- http://josm.openstreetmap.de/josmfile?page=Styles/light_source&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryHistoryDialog$RedoAction@49220604
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryFilterDialog$UpdateAction@53e469da
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryFilterDialog$ResetAction@59572235
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.measurement.MeasurementDialog$1@346716fa
- E: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.NullPointerException. Cause: java.lang.NullPointerException

OSM API: http://api.openstreetmap.org/api

=== REPORTED CRASH DATA ===
MapView#paintLayer:
 - layer: org.openstreetmap.josm.gui.layer.WMSLayer@6b0f32c
 - bounds: Bounds[58.3540984,26.7199537,58.355097,26.7223541]

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.getScaleFactor(AbstractTileSourceLayer.java:295)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.getBestZoom(AbstractTileSourceLayer.java:305)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.paint(AbstractTileSourceLayer.java:1449)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:754)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:825)
	at javax.swing.JComponent.paintChildren(JComponent.java:889)
	at javax.swing.JComponent.paint(JComponent.java:1065)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:290)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12964.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.